The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Problems with UK post codes, and other OmniFocus 1.5 issues Thread Tools Search this Thread Display Modes
A few annoyances with OmniFocus iPhone 1.5 that I've noticed straight away:

1. You can (apparently - I haven't tried) now open links in your actions within the app without being taken to Safari instead, yet the Help files close OmniFocus and launch Safari!?

2. Adding and editing locations seems completely counter-intuitive to me now. Rather than being able to do it from the Nearby views, you can only do it from the Context view in Edit mode (unless I am missing something).

3. OmniFocus is also giving me some whacked out results for locations. E.g. my home location is shown as being 1km away, yet when Google Maps is opened to show the route (why not do that in app as well by the way?) it is where it should be, right here!

4. Trying to edit locations feels broken as the buttons and text entry fields remain completely unresponsive for a while (I assume it is updating any data for the entered locations but no visual feedback is provided).

Last edited by JKT; 2009-06-17 at 01:55 PM.. Reason: Renamed thread as now listing more than one problem
 
With regard to 3., I don't know why but OmniFocus is consistently showing the wrong locations on the map for things I have entered addresses for (city and post code) whereas they are in the right place when using the same data in the Google maps app. E.g. OmniFocus is putting my work place in the middle of Regent's Park, yet it is in Camden...
 
5. I've just checked an entry that I know repeats to see how the feature is implemented and there is an UI flaw for this - when viewing the action, the entry is correctly shown as repeating every 3 weeks. However, when I click the Repeat field to edit it, the 3 weeks data is not included in the view and the time entry field is blank. I think it would be better for it to show the current data until you change it, otherwise you can be left thinking that it has erased your entry by mistake.

P.S. Btw, a nice set of new features, regardless of the above problems...
 
Quote:
Originally Posted by JKT View Post
With regard to 3., I don't know why but OmniFocus is consistently showing the wrong locations on the map for things I have entered addresses for (city and post code) whereas they are in the right place when using the same data in the Google maps app. E.g. OmniFocus is putting my work place in the middle of Regent's Park, yet it is in Camden...
I had this problem with earlier releases of OF, but it was fixed in the last build, or two. I too see that this has reappeared in 1.5. The blue pin for my actual GPS position is correct, but the green 'start' pin can be a mile or more away.
 
#1 and #5 both fell into the "we wish we had time to fix this" bucket - some of the changes that were made between OS 2 and OS 3 would have caused <1.5 releases to crash on the new OS. We didn't want to hold up those fixes. We're planning a 1.5.1 release soon to address stuff like this.

#2 - We tried an interface with both the edit and map/list toggle button, but they ended up pretty small and hard to tap. Until we come up with a better solution, we've given the contexts with location info a different icon in list mode so folks can tell which ones still need info added. (Contexts with location info get a crosshair on their icon.)

#3 - we'd need more info to be sure exactly what's going on. From work with a previous customer, I believe OmniFocus currently uses the first location results it gets back, even if more accurate results become available later on.

Greg's post makes it sound like this is what's going on. The green pin is the location we get back from cell phone triangulation. It's generally the fastest to respond, but is rarely the most accurate.

(In-app directions aren't supported yet, btw - hoping a future OS update makes them possible.)

#4 - hmmm... I'm getting pretty good responsiveness out of my 1st-gen iPhone when I edit a location, even with WiFi off. (Maybe half a second between button tap and keyboard appearance?)

It's possible your UK location is related to the issue - maybe Google lookups are taking longer? In any case, adding an action to my Brighton context to re-test this when I visit later this month. :-)

If you could send along screenshots and/or more details on the contexts you're having trouble with, that'll help nail this down.

Last edited by Brian; 2009-06-17 at 03:18 PM.. Reason: whitespace/formatting
 
Thanks for the responses Brian (can you alter my thread title to something more generic - I've added more than the single issue I started it out with). It's pretty late here so I'll try and do the screenshots tomorrow or at the weekend.

However, I've tracked down what the source of the problem is... OmniFocus really doesn't like British Post Codes! If you put the address in without a Post Code, and assuming it finds the right road this way, it will display in the correct location in the map. However, if you enter an address with a Post Code, it ends up being located a good km or more away from its actual location on the OmniFocus map (the best so far has been 617km for my home address!). In contrast, the Google Maps app has no problem with Post Codes being included.

#4 Actually, that was my mistake due to what I would consider an UI design flaw. I was trying to tap the entry for previously created locations rather than tapping the pertinent button for the desired setting. I think there are two issues here - firstly, the buttons don't look enough like buttons and, secondly, when you already have an address or location in the address text entry field, it makes sense that you should just be able to tap it to edit it the data whereas at the moment it doesn't seem that you can. Hence my blindly tapping away expecting something to happen and thinking that it was doing something else.
 
Jonathan - thanks for the info. Just as an experiment, does adding/removing "United Kingdom" from the street address have any effect in OmniFocus? Ideally, we shouldn't be requiring that, of course; just want to know if it changes the behavior.

We've got a feature request open on the ability to edit existing locations - I'll vote that up on your behalf. :-)
 
Things I have tried:

1. Post code alone - I get located some 617 km away in the US! If I add UK to this, I get located back in (the wrong place though) the UK.

2. Adding UK or United Kingdom to the end of the address - locations are still offset from their actual address by a few km.

3. Removing commas from my Address entries - still offset.

Seems like there is no easy fix for this from the user perspective, other than not including a Post Code.

Edit: The risk with not having a Post Code is that you might not find the right location - many roads in the UK share the same name (e.g. there are at least two Gloucester Roads in London) so if you aren't careful with your address input and/or don't know the name of the area that the road is in, OmniFocus could find the wrong one and it would be difficult to know.

A feature request - some means of showing on the map where a newly entered location is actually being situated. At the moment, unless a context has active actions, it isn't easy to find where the location for that context has been situated by OmniFocus.

An alternative - show all locations on your map, with e.g. green pins for ones that have actions and red ones for those that don't.

Last edited by JKT; 2009-06-17 at 11:35 PM..
 
A further update on this:

You can type the first half of the Post Code and it will work, but if you include the second half it will fail. Fwiw, the first half of a Post Code will tell you what borough your location is based in, but the second half pinpoints the actual building(s) within the borough. So it only helps to narrow down the search to an actual street and not the place within the street.
 
Btw, I've also submitted this as a bug report via e-mail.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Clipping into OmniFocus from Outlook 2011 [See post #34] PeterRHawkes OmniFocus 1 for Mac 36 2014-05-03 05:21 PM
Know of an iOS app that supports "Send to OmniFocus"? Post here! endoftheQ OmniFocus for iPad 21 2013-11-08 01:15 AM
OmniFocus and World of Warcraft issues. Branwell OmniFocus 1 for Mac 5 2009-02-17 08:17 AM
problems with typing in email codes mitchellm OmniOutliner 3 for Mac 2 2006-07-11 02:17 PM


All times are GMT -8. The time now is 12:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.