The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OmniFocus Web Interface still running. How can I disable it? Thread Tools Search this Thread Display Modes
I saw a reference to a post about this but cannot for the life of me find the actual post. I am seeing the following in my console logs and want it to stop:

Jan 12 09:18:53 Cyberiad7 com.apple.launchd[93] (com.omnigroup.omnifocus.web_interface[52375]): Bug: launchd_core_logic.c:2938 (23433):2: chdir(j->workingdir) != -1
Jan 12 09:18:53 Cyberiad7 com.apple.launchd[93] (com.omnigroup.omnifocus.web_interface[52375]): open("log/production-stdout", ...): No such file or directory
Jan 12 09:18:53 Cyberiad7 com.apple.launchd[93] (com.omnigroup.omnifocus.web_interface[52375]): open("log/production-stderr", ...): No such file or directory
Jan 12 09:18:53 Cyberiad7 com.apple.launchd[93] (com.omnigroup.omnifocus.web_interface[52375]): posix_spawn("/Users/aaffleck/Library/Application Support/OmniFocus/Web Interface/script/server", ...): No such file or directory
Jan 12 09:18:53 Cyberiad7 com.apple.launchd[93] (com.omnigroup.omnifocus.web_interface[52375]): Exited with exit code: 1
Jan 12 09:18:53 Cyberiad7 com.apple.launchd[93] (com.omnigroup.omnifocus.web_interface): Throttling respawn: Will start in 10 seconds

Can someone direct me to the post which describes how to shut this off?

(It's from an early sneakypeek where I turned on the web interface... the feature was removed before I turned it off and now it perpetually tries to launch)

-A
 
I deleted the OmniFocus Beta some time ago and tonight while trying to trace a problem in another application I saw these messages in Console.app.

4Thursday24/January/08 9:14:13 PM com.apple.launchd[88] (com.omnigroup.omnifocus.web_interface[513]) Bug: launchd_core_logic.c:2938 (23433):2: chdir(j->workingdir) != -1
4Thursday24/January/08 9:14:13 PM com.apple.launchd[88] (com.omnigroup.omnifocus.web_interface[513]) open("log/production-stdout", ...): No such file or directory
4Thursday24/January/08 9:14:13 PM com.apple.launchd[88] (com.omnigroup.omnifocus.web_interface[513]) open("log/production-stderr", ...): No such file or directory
4Thursday24/January/08 9:14:13 PM com.apple.launchd[88] (com.omnigroup.omnifocus.web_interface[513]) posix_spawn("/Users/bwilkins/Library/Application Support/OmniFocus/Web Interface/script/server", ...): No such file or directory

I deleted OmniFocus with AppZapper but there seems to be something hanging around that's using system resources. I'd be very grateful if someone from OmniFocus could tell me how to sort out this problem.

Thanks in advance.

Bill

Last edited by Brian; 2008-01-25 at 04:43 PM.. Reason: Made title more searchable
 
You have a launchd item trying to launch the web app.

I don't know where the original webapp installed its launchd item, its just a plist.

The first place to look would be ~/lib/LaunchAgents

Otherwise download Lingon:
http://lingon.sourceforge.net/

It will show you all your launchd agents

-P
 
delete this file:
~/Library/LaunchAgents/com.omnigroup.omnifocus.web_interface.plist
 
Thank you both. Problem solved.

Bill
 
Quote:
Originally Posted by Lizard View Post
delete this file:
~/Library/LaunchAgents/com.omnigroup.omnifocus.web_interface.plist
I spoke too soon deleting the file and re-starting several times and the message still appears in Console.app.

Any ideas where else this could be hiding?

Bill
 
Quote:
Originally Posted by ptone View Post
You have a launchd item trying to launch the web app.

I don't know where the original webapp installed its launchd item, its just a plist.

The first place to look would be ~/lib/LaunchAgents

Otherwise download Lingon:
http://lingon.sourceforge.net/

It will show you all your launchd agents

-P
I've tried Lingon as you suggest. It's great the way the yellow popup box shows you what is happening. However I still can't find the problem.

Does this help?
4Friday25/January/08 6:52:00 PM com.apple.launchd[124] (com.omnigroup.omnifocus.web_interface[905]) Bug: launchd_core_logic.c:2938 (23433):2: chdir(j->workingdir) != -1
4Friday25/January/08 6:52:00 PM com.apple.launchd[124] (com.omnigroup.omnifocus.web_interface[905]) open("log/production-stdout", ...): No such file or directory
4Friday25/January/08 6:52:00 PM com.apple.launchd[124] (com.omnigroup.omnifocus.web_interface[905]) open("log/production-stderr", ...): No such file or directory
4Friday25/January/08 6:52:00 PM com.apple.launchd[124] (com.omnigroup.omnifocus.web_interface[905]) posix_spawn("/Users/bwilkins/Library/Application Support/OmniFocus/Web Interface/script/server", ...): No such file or directory
4Friday25/January/08 6:52:00 PM com.apple.launchd[124] (com.omnigroup.omnifocus.web_interface[905]) Exited with exit code: 1
4Friday25/January/08 6:52:00 PM com.apple.launchd[124] (com.omnigroup.omnifocus.web_interface) Throttling respawn: Will start in 10 seconds
 
Sorry for the confusion here. I'll insert the info from the original release note here and edit the title to make this more searchable for other folks with the same problem.
October 9: Disabled the preferences for the web interface.

If you're already running the web interface, it will remain running for now. You can permanently stop it by running this command in a Terminal window:

Code:
launchctl unload -w ~/Library/LaunchAgents/com.omnigroup.omnifocus.web_interface.plist
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
OmniFocus web interface amelchi OmniFocus 1 for Mac 3 2012-07-08 07:35 PM
OmniFocus is Crashing! [Contacted our team; back up and running.] PeterRHawkes OmniFocus 1 for Mac 2 2010-07-19 11:14 PM
A fix for OmniFocus running slowly dbyler OmniFocus 1 for Mac 3 2009-10-02 02:40 PM
Will Omnifocus for iphone can keep running in background as Mail application elle007 OmniFocus for iPhone 1 2008-07-30 09:55 AM
New Version of OmniFocus Web Interface [Old Thread] dansays OmniFocus 1 for Mac 101 2008-01-18 08:46 PM


All times are GMT -8. The time now is 01:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.