The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OmniFocus not syncing; hanging; not starting; etc Thread Tools Search this Thread Display Modes
Can anyone help with this?

I've got OmniFocus on a desktop and an iPhone, with a local WebDav server setup (as per their instructions). Everything was working pretty good for quite a while UNTIL....

I got a recent update. Noticed that the iPhone sync was never completing. Then noticed that the sync on OmniFocus was trying to sync, but never seemed to start. Had to force quit OmniFocus, but then it would never restart (would just hang, gobbling up CPU).

Suspected that the DB was corrupt, so used Time Machine to pull one forward from a day or two ago. I also deleted the file from the WebDav area. OmniFocus started fine, and synced to WebDav fine. ONCE...

The second time I try to sync, the sync operation goes ALMOST to completion, then hangs. After that, I'm completely screwed again. I have to force quite OmniFocus, but then it won't restart again, and I have to recover the DB again.

Any suggestions? Weird voodoo magic incantations to do?
 
Hi Dave,

what size is the file in your webdav directory?

maybe you can give it a try and export your database to an OmniFocus file (after restoring from Time Machine) and then revert to database backup selecting that exported file. That way, you've got at least a "clean" OF file (OmniFocus.ofocus).

When you sync that to your local webdav server, it should work.

Hope that works...

Regards
Boris
 
I am using OminFocus on my mac laptop and also syncing it to my iphone. I have been using the desktop program and iphone version pretty much without issue for a few months now. Love the program but now I can't get in!

I usually get a daily "program update" notification from you which I update each time. The last one I did the other day totally messed up my desktop program. I click on the OmniFocus icon and although the main menu bar appears the main window does not -- in my applications sidebar it appears that there are multiple versions of OmniFocus opened all at once. I tried to delete all but the latest and it still does not work. The main window is not hidden. I tried everything. This actually happened before when I downloaded an update and I kept getting the message that OmniFocus could not open because it was "locked". I don't know what I did to fix this but the main window did eventually open.

So.....right now....I can see and use the program on my iphone. I cannot see or use the program on my mac. I tried to download the latest sync version program from your website but that does not help. I tried to download an older version (a few weeks old) and that did not work. I found the sync file on my idisk and when I click on that it does actually open OmniFocus as I know it but I don't think I should be working in that file. I did add an entry and it did not sync to my iphone even when I did a manual sync. I kept this file on my idisc where it was but I don't think that is the correct file I need to open on my mac to use the program.

Additionally....am I doing something wrong when I update? Every time I get an update notification I choose to update and it puts the program on my desktop....I have about 30 OmniFocus icons on my desktop or in my Applications folders. I am always confused as to which one I need to click on.

Anyway, first things first......how do I get my desktop program to work again? And once I do, how do I make sure the correct data is in there?

Thanks
Angie
 
Quote:
Originally Posted by roniABC View Post
I am using OminFocus on my mac laptop and also syncing it to my iphone. I have been using the desktop program and iphone version pretty much without issue for a few months now. Love the program but now I can't get in!

I usually get a daily "program update" notification from you which I update each time. The last one I did the other day totally messed up my desktop program. I click on the OmniFocus icon and although the main menu bar appears the main window does not -- in my applications sidebar it appears that there are multiple versions of OmniFocus opened all at once. I tried to delete all but the latest and it still does not work. The main window is not hidden. I tried everything. This actually happened before when I downloaded an update and I kept getting the message that OmniFocus could not open because it was "locked". I don't know what I did to fix this but the main window did eventually open.

So.....right now....I can see and use the program on my iphone. I cannot see or use the program on my mac. I tried to download the latest sync version program from your website but that does not help. I tried to download an older version (a few weeks old) and that did not work. I found the sync file on my idisk and when I click on that it does actually open OmniFocus as I know it but I don't think I should be working in that file. I did add an entry and it did not sync to my iphone even when I did a manual sync. I kept this file on my idisc where it was but I don't think that is the correct file I need to open on my mac to use the program.

Additionally....am I doing something wrong when I update? Every time I get an update notification I choose to update and it puts the program on my desktop....I have about 30 OmniFocus icons on my desktop or in my Applications folders. I am always confused as to which one I need to click on.

Anyway, first things first......how do I get my desktop program to work again? And once I do, how do I make sure the correct data is in there?

Thanks
Angie
The default for the upgrader is to keep the old version, with a new name reflecting the version number.



Uncheck that "Archive existing version" box and you won't get the endless accumulation of old versions. Then, delete all of them except the one called simply OmniFocus. I would quit OmniFocus (all of them!) before doing all of this, just to make sure you aren't running one of the versions you're trying to delete.

At this point, you should probably be able to start OmniFocus without incident. The lock message reflects that you are trying to start another instance of OmniFocus while the database is locked (the program isn't written to allow two or more copies to write to the database on your local disk simultaneously, so the first one to start "locks" the database by creating a file called OmniFocus.ofocus.lock next to the database in ~/Library/Application Support/OmniFocus. If another copy of OmniFocus tries to start up, it sees that file and complains rather than possibly corrupting your data. If, after quitting all running copies of OmniFocus, you still get that error message when starting OmniFocus, you can fix the problem by quitting OmniFocus (again, all of them!) and removing that file.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fresh start/Starting over (Resetting OmniFocus to default data) [See thread.] Phibermaster OmniFocus 1 for Mac 8 2012-08-31 04:12 AM
OmniGraffle 5.3 hanging on Lion [A: Finder was hanging.] rsmithgi OmniGraffle General 1 2011-07-25 07:18 AM
Starting a basic Workflow with OmniFocus tjslogic Applying OmniFocus 3 2011-04-18 07:09 PM
Starting Over with OmniFocus: Mac + iPhone danglickmd Applying OmniFocus 3 2010-04-05 05:08 PM
preventing omnifocus from starting up by itself counterpt OmniFocus 1 for Mac 6 2009-01-03 11:08 AM


All times are GMT -8. The time now is 10:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.