The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Missing "Show in xxx Mode" shortcut? Thread Tools Search this Thread Display Modes
Folks, my shortcut for "Show in [planning|context] Mode" is gone. Menu item is still there but... why? An oversight on Omni's part? Or part of a conscious decision?

(Yes, filed via feedback.)
 
I'm sorely missing it as well. I always use it to switch from Context to Planning mode to remember the context of my Next Actions. Now, it's far too many clicks away.
 
The Switch button has been broken since at least rev 95721. I sent feedback on rev 95744, and there are a couple threads on the topic in this forum.

Hopefully, it'll make the cut before January. But I'm sure OG is pretty busy right about now. ;-)
 
the switch button is working for me with the latest build 96060
 
It's not working for me in rev 96060. It behaves as it has since it was broken: I select an action in Planning Mode, click the Switch button and OF just sits there for a second or two and then beeps. If I then manually switch to Context mode, I can see OF tried to do something as View setting are all changed.

I see similar behavior when in Context Mode with an action selected and click the Switch button.

ext555: What exactly are you doing to make this work? Maybe I'm just doing something wrong?
 
Aha! I think I've found the source of the discrepancy.

I had the LeaveEmptySelectionEmpty hidden default turned on (see this thread for more info). When I turn it off, the Switch button works again.

jasong, kraigparkinson: Do you guys have that hidden default turned on? You can verify the setting by running this in Terminal (1 = on, 0 = off):

Code:
defaults read com.omnigroup.OmniFocus LeaveEmptySelectionEmpty
I still prefer the LeaveEmptySelectionEmpty setting on, so maybe OG will fix this.
 
@Toadling:

Thank you! I was having the same problem and was really glad to find this answer.

(Still don't have a keyboard shortcut, but I can live without that for a while.)
 
Unfortunately, the Switch button still seems to be broken in the most recent build (rev 96088) when the LeaveEmptySelectionEmpty hidden default is enabled, despite restoring the keyboard shortcut for Show in [Alternate] Mode.
 
The keyboard command, the original concern, is back and working in the latest seeds.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Omnifocus: Send to Inbox" Service is Missing chipwarren OmniFocus 1 for Mac 1 2012-07-02 09:13 PM
Missing "ToDo" in "Due" area [A: Poster confused about how Due field works.] morkafur OmniFocus 1 for Mac 3 2012-05-24 03:39 AM
Hierarchical tasks don't appear in Due? [A: Enable "show groups in context mode"] alexp OmniFocus 1 for Mac 3 2012-02-10 11:03 AM
How to show completed actions? [A: use View menu ("Eye button") to show All] Patrick923 OmniFocus for iPad 2 2010-08-06 07:10 AM
How to show an item in one mode in the other mode? [A: View menu or "Switch" button] ckennedy OmniFocus 1 for Mac 4 2010-06-27 05:23 AM


All times are GMT -8. The time now is 05:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.