The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
UI prob: app prefs say "autocomplete", project inspector says "don't". Former wins. Thread Tools Search this Thread Display Modes
Hey guys, I use single actions lists for a lot of things and I don't want them to go away when I complete all the actions within them. I unchecked the "Mark complete when completing last item" box on OF for Mac, but that rule doesn't seem to go over to my iPhone.

Heeeeeeelp! :)
 
I just made a SAL, added a few items, synced it over to my iPod, ticked them off, and didn't have the SAL auto-complete. My guess is that perhaps you had the default set to auto-complete when you created the SAL and didn't uncheck that for the SAL -- the default controls how the project will be set up and subsequent changes to the default do not change the pre-existing projects. You have to select the project/SAL in the inspector and uncheck the corresponding box there.

If my guess is wrong and you can create a new SAL and demonstrate the unwanted auto-completion bit I'm sure the support ninjas would be very interested to see how you do it!
 
Well I feel like a stupid dummy. For some reason it didn't stick the first time around, but after unchecking the box and syncing again, it worked.

THAAAANKS! :]
 
I'm still not sure that I correctly understand where you did which steps, but I can describe a scenario that would produce the behavior you apparently experienced. If you changed the auto-complete setting on your Mac, then before syncing your Mac and your iPhone (remember, both devices need to do a sync, and in the right order, before the updated data will be propagated everywhere) you completed the last action in that SAL, you would get the auto-completion because in the iPhone's database, that SAL was still marked to auto-complete. Only after the Mac wrote out the updated data to the central repository, and the iPhone subsequently read it and updated its local repository, would the auto-completion be turned off.
 
Alright, I made absolutely sure that the box was unchecked. I synced both the iPhone app and the Mac app and the box stayed checked. I later completed all the actions in my SAL on the phone and it went away. Whaaaat?!
 
Michael, if you open up the Settings pane, what do you have selected for the "In projects, show" setting?

If you have "Available" selected, that could explain why the project isn't being shown. Try "Remaining" or "All" instead.
 
It's set to remaining but that's not really the problem. I don't want the SAL to auto-complete. For whatever reason the iPhone app is overriding the "Mark complete when completing the last item" checkbox and re-checking it once I complete the last action. ]:
 
Yeah, if the project view is set to Remaining, the list shouldn't be disappearing.

I tried repeating your steps and couldn't get the phone app to behave in the manner you're seeing, but if you can compress your sync database from the server and send it to the support ninjas, we can look at the transactions and see exactly what's going on here. Sorry for the trouble this is causing!
 
Michael - thanks for sending in your data! I'm not sure what is causing this, but I was able to reproduce the behavior you're describing. I've handed the issue off to the dev team for more research.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Bad Gateway" sync prob. on iPod [SOLVED: Restart OF on Mac if network changes] el_jimo Bonjour sync 3 2009-03-17 01:21 PM
Toggle from "Contexts" to the "Project the Entry belongs to"?? jkrytus OmniFocus 1 for Mac 1 2008-01-17 01:46 PM
Project context menu: "Complete" vs. "Completed" vocaro OmniFocus 1 for Mac 6 2007-12-11 09:18 AM


All times are GMT -8. The time now is 07:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.