The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniPlan > OmniPlan General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OmniPlan Server Repository: Publish Failure Thread Tools Search this Thread Display Modes
I must be missing something with the OmniPlan Server Repository capability, as far as I can tell it is pull only, no push beyond initial project publication.

Example...

I have a standard WebDAV server with full access, configured and 'test' capability works just fine, but after I add the "Sync with OmniPlan server repository" Publish/Update Action in and hit Save on the local file, I get the error:

"You need to update to the newest version of the project before publishing your changes."

So I go back, use "Project" -> "Update", make changes, local file updates, but changes never appear to make it back to the Server Repository.

In other words, if I close the local file, then use the File -> Open from Server Repository, the changes made to the local file are simply not there.

Assuming "Publish" means push to server, "Update" means pull from server, yet there does not appear any way of getting the server-side file updated with the local-side changes after the initial server push.

What am I missing here?
 
Just checking in to see whether you might have found a fix?

We're also running into the same issue. However, our WebDAV does work for the other Omni products like OmniFocus (Mac, iPad, iPhone), OmniGraffle (iPad), plus others like Pages (iPad, iPhone), iThoughts (iPad, iPhone), Finder, etc...

We can Publish and Delete, but we can't Update...
 
We've done a number of experiments with different WebDAV setups and this is what we found:

CentOS 5.7, Apache 2.2.3 configured for WebDAV does NOT work. We reproduce the same issues above. 412, Precondition error during update.
CentOS 6.2, Apache 2.2.15 configured for WebDAV works!
CentOS 5.7, Apache 2.2.22, manually built and installed configured for WebDAV works!

For 2.2.15, the following can be referenced for the WebDAV setup:

http://www.cyberciti.biz/faq/rhel-fe...enable-webdav/

For 2.2.22, we used the "OSX" based as a reference for the WebDAV setup. OSX Lion comes with 2.2.20:

http://manas.tungare.name/blog/howto...v-on-mac-os-x/

(The default group for 2.2.22 is daemon:daemon, instead of www:www)

I hope this helps!



Kenton
 
Hmm - I'm having this issue all of a sudden publishing to iCloud calendars - this morning it's fine, this afternoon it's not.
 
I am also facing the same issue. Please share your experience if you have found any solution to this issue.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Omnisync server error won't allow publish from MBP lawz808 OmniPlan General 2 2013-06-21 02:44 AM
Open Server File Failure kotic OmniPlan General 1 2012-11-01 04:24 PM
Nothing shows up in Manager Server Repository after syncing jperegrino OmniPlan General 2 2011-08-18 07:06 AM
OmniPlan Server / Multi-User Edition DzynLab OmniPlan General 7 2008-03-15 05:08 AM


All times are GMT -8. The time now is 06:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.