The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Other WebDAV
FAQ Members List Calendar Search Today's Posts Mark Forums Read Sync Problems in OmniFocus 1.8 [Bug: workaround in thread] Thread Tools Search this Thread Display Modes
The upgrade to 1.8 seems to have broken my WebDAV sync. [Thanks for backing up previous versions of the app during upgrade -- downgrading to 1.7.5 is my temporary fix.]

When retrying a failed sync in OmniFocus 1.8, I get the error:

Unable to synchronize database with server.
Unable to read document.
Unable to read the contents of "https://mydomain:2078/OmniFocus.ofocus/".

(where mydomain is, of course, my domain).

Details of my sync setup:
* Domain hosted by
* SSL certificate is signed as Bluehost, not as my own domain (old versions of OF would periodically warn me about that before sync, as I would want!)
* Same Apache server is serving out a Drupal instance higher up the directory tree with some mod-rewrite rules (but since I can still sync from 1.7.5, it seems that the change has to be client-side)

Other things I've tried:
* When I use the "Connect to Server" menu item to connect to https://mydomain:2078/ I successfully mount the appropriate directory (~/public_html/omnifocus/) which contains the OmniFocus.ofocus bundle.
* Re-imported the x-omnifocus-settings:/// URI which I'd used to export these setting to my other sync locations (on Jan 13 2009)
* As mentioned, 1.7.5 works flawlessly.

Running OS 10.6.4.

Any help would be appreciated!
You should contact the support ninjas directly for assistance, either via Help->Send Feedback or telephone (800-315-6664 or +1-206-523-4152). They'll be back in the office Monday at 10 AM PDT.
Sorry about this! It looks like the security certificate setup that bluehost uses is triggering a problem in 1.8; we'll work around this in an update, but in the meantime, the following steps should get you back up and running:
  1. Open OmniFocus for Mac's sync preferences.
  2. Copy the entire text of the Location field.
  3. Open Safari.
  4. Paste the text you copied from OmniFocus into the location field. Hit return.
  5. Safari will attempt to open your sync location, popping up a warning about the security certificate the site uses. Press the "Show Certificate" button.
  6. You should see a checkbox next to text that reads "Always trust when connecting to <your sync server>". Check the box, then hit Continue.
  7. Restart OmniFocus. You should be able to sync now.

If that doesn't fix the problem, contact our support ninjas by email or phone (800.315.6664) and we're happy to help. Sorry for the trouble in the meantime!
Okay, it looks like there are actually two related problems. One affects folks, and the other affects folks whose Sync servers use cPanel.

Info on the second problem incoming, but I'm going to put it into it's own post. (Bluehost offers a "web disk" feature which uses cPanel, so there's a lot of overlap here. There are probably folks out there that have cPanel access through other providers, so I want to be able to link to the two solutions independently.)
It appears that sync servers using a software package called cPanel sometimes (but not always) handle the names of files we send them in a way that other sync servers don't. Bluehost and other hosting providers include cPanel in their hosting packages.

When OmniFocus syncs with a cPanel server, we observe that some (but not all) of the files we upload are processed differently than other web servers do. We send the file with one name, but when the server stores the file, it changes the file name. As far as we know, cPanel is the only server package that behaves this way.
Nerdy digression: Specifically, cPanel appears to sometimes (but not always) URL-encode the file names multiple times. For example, they convert "=" to "%3D" and "+" into %2B". This is pretty normal. What cPanel does, though, is then convert the "%" characters. Other web servers don't do that, because the url encoding for "%" is... "%25". It's actually longer, and contains the character they're encoding.
In any case, OmniFocus for Mac has a workaround in place for this idiosyncrasy - during a normal sync, we reverse their process and put the names back the way we expect them to be.

However: if the database on the Mac gets deleted, OmniFocus handles things differently. We copy the database back down from the server to the Mac, but then we don't apply the cPanel-specific workaround that our regular sync code does. At that point, the file names in the database on your Mac are left in a state that OmniFocus doesn't know how to work with.

We'll add the work around to the "replace my database with the servers' database" code in an update. In the meantime, we've written a script which has (so far) worked to repair the file names without requiring folks with this problem to send their databases to us.
IMPORTANT NOTE: If you are not having this exact problem, please do not run the script. If you're having a different problem, the script may make things worse, rather than better!

If you're not sure this script will help, contact the support ninjas before doing anything else.

(Some folks may remember the "smooshing" script from a few years back; they probably also remember what I'm worried about here.)
If you're having this problem, you should be able to get back up and running by quitting, then using the steps below. If you're not able to sync at the end, contact us and we can help.
  1. Quit OmniFocus.
  2. Open the "Utilities" folder in your Applications folder.
  3. Launch the "Terminal" app in that folder.
  4. Unzip the attached script file, then drop it on the open Terminal window.
  5. Hit return to run the script.

Hope this helps!
Attached Files
File Type: zip (909 Bytes, 1255 views)
I have tried the safari certificate. Did that. No change in Omnifocus. Then ran script in Terminal. Still no change. Could you send me access to the omni sync server. Need this fixed. No issue till update to 1.8
I have also not been able to sync since the 1.8 update. I don't use bluehost, but my WebDAV host does use cpanel. I tried the safari certificate trick above and that didn't help. I don't really understand the post regarding the file naming, and I certainly don't want to replace the database on my Mac with the server copy, since the server copy is now very out of date. I tried contacting support but never got a response (it's possible IT at my office blocked it for some reason).

I guess I will try signing up for the Omni sync server, or maybe downgrade back to 1.7.
Ethant, I checked our trouble ticket system for mail from the address you used to create your forum account, but I'm afraid I can't find any. Maybe it did get blocked or lost in transit?

You may want to try emailing from another email address, or contacting our support ninjas by phone. The number here is 1.800.315.6664 and we're available until 5pm Pacific time. We can help.
Brian -

Thanks, I really appreciate your reply. I filed the ticket using my work e-mail, and our IT is, shall we say, overzealous when it comes to filtering e-mail, so I would not be surprised if that was the problem.

In any case, I signed up for the Omni Sync service yesterday and it seems to be working well. I think I will just stick with that for now and not worry about this.

Thanks again!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Keychain Behavior in Mac OS X 10.8? [A: bug in 10.8 - see thread for workaround.] chmars OmniFocus 1 for Mac 4 2012-09-26 01:18 PM
Trouble pasting Chrome links/URLs [Known issue: see thread for workaround.] hawkettc OmniFocus 1 for Mac 15 2010-08-24 08:15 AM
WebDav Omnifocus & Bluehost - how to connect with my mac?? stevecommathe Other WebDAV 1 2010-05-04 02:03 PM
Problems with sync WebDAV (Bluehost) benwhite Other WebDAV 5 2008-09-28 07:47 AM
OmniFocus, WebDav, and BlueHost afuggetta OmniFocus for iPhone 0 2008-07-15 01:57 AM

All times are GMT -8. The time now is 01:13 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.