The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Other WebDAV
FAQ Members List Calendar Search Today's Posts Mark Forums Read

No Initial Sync from iPhone Thread Tools Search this Thread Display Modes
I've can't get OF for iPhone to perform the initial sync with a Swiss Disk account and I hope someone will be able to help.

I have OF for Mac running on OS X 10.6.5. OF/Mac syncs when I start it, or manually, without any trouble. I can sync manually on my home WiFi network as well as over a home ethernet connection. I have verified that the OF items in OS X keychain are correct.

I have tried to perform an initial sync from OF/iPhone to Swiss Disk many times. I open OF/iPhone, select "Set Up Sync", Open OF/Mac Preferences, select Sync>Advanced>Share Settings, and the settings are successfully transferred. I have verified that the web address for the Swiss Disk server is correct by going into "Set Up Manually" on OF/iPhone and looking at it. I cut and paste the User Name and Password from their saved location in 1Password, and I have verified that they are correct. The "Preparing to Synchronize" message appears and there it stays. There is no movement on the progress bar.

I am using an iPhone 4 with iOS 4.1 running. I have tried deleting the app from my iPhone and reinstalling it. I have restarted the iPhone. I have also done both of these in sequence. I have tried performing the initial sync over 3G with WiFi disabled. I have deleted the app and then performed the upgrade from version 1.7 to 1.8, when it appeared on Nov. 17. I have even tried to start things using "Make New Database" instead of "Set Up Sync" as detailed in the last item currently on the OmniFocus for iPhone Faq. I have uninstalled and reinstalled the app between experiments to avoid the possibility of troublesome legacy settings. Nothing works.

The database is very small. I have created 4 or 5 folders each in Project View and in Context View and have used them to organize about 20 projects and contexts respectively. Most of them are empty. I have a total of 5 actions. Nevertheless, I let one sync attempt go for about 15 minutes before I closed OF.

My router is locked up pretty tight but I don't think that could be the problem, or why wouldn't the attempt on 3G work?, so I will spare you the AirPort settings. In any case. I have no other problems using the iPhone over this network, including Evernote, which as you may know also syncs local info to a remote server although it's not WebDav.

Please forgive the length of this post, but I have been trying to eliminate possibilities which occurred to me by reading previous entries on this forum. Does anyone have any suggestions?
Don't bother fooling around with SwissDisk, just sign up for a free account on the Omni sync server at and be done with it. Among the advantages there's one that stands out: your provider of sync services will be intimately acquainted with your sync needs, and will know everything there is to know about repairing your data, should it ever come to that.
By the way, the support ninjas will help you work on this if you are determined to use SwissDisk; use Send Feedback from the iPhone to contact them, or call them at 800-315-6664 or +1-206-523-4152 during business hours in Seattle. I'm pretty sure you'll hear them suggest what I did somewhere in the discussion, though :-)
BlitzB, as Bill mentioned, we'd be happy to help. One thing I thought of which may help...

If you open up this folder on your Mac:
<your home folder>/Library/Application Support/OmniFocus

and do a Get Info on the "OmniFocus" or "OmniFocus.ofocus" file you see in that folder, how large is it? That info will help us figure out if there's a large quantity of data in the app which isn't visible (completed actions, for example) or if there are any file attachments in there. Either of the above could cause the amount of data being synced to the phone to be very large, even if there are a small number of visible projects/actions/contexts in the database...
Thank you, Bill and Brian. File size is only 8 KB, though. I have to go out for a few hours, so unless you have any other ideas, I'll follow up in the morning with Support.

I like the idea of the support that Omni can provide with their own Sync Server, but I'd be happier if the file was encrypted or at least password-protected. No offense meant. I just have to think through my obligations on work-related material. I appreciate your help.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedier sync and start-up times on iPhone 4? Omni Sync helps? mcogilvie OmniFocus for iPhone 1 2010-08-14 09:00 PM
Can't Get Through Initial 1st Sync & Now OF is Acting Odd. HappyDude Other WebDAV 4 2009-09-06 03:06 PM
Sync fails after initial sync on Windows Server 2008 [Server Bug] Shortie Other WebDAV 5 2009-07-16 09:20 AM
Initial Sync jmelvin Bonjour sync 4 2009-07-15 10:11 AM
Can't do initial sync with iPhone kongjie OmniFocus for iPhone 7 2009-06-24 01:09 PM

All times are GMT -8. The time now is 12:58 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.