The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniPlan > OmniPlan General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Omnisync server error won't allow publish from MBP Thread Tools Search this Thread Display Modes
I have worked very hard to create a very in-depth project plan in OmniPlan instead of Microsoft Project, because I like the interface better and the ability to sync to my iPad when travelling appeals to me. Now I'm stopped dead in my tracks. When I try to publish the new plan, I get the following:

"An error occurred while publishing.

You need to update to the newest version of the project before publishing your changes."

Which is interesting, because I've never published the file to the server before. But I bite and select update. Then I get:

"An error occurred while updating.

not found?

That error makes sense because the file was never published. And the mobius strip of frustration begins...

I've uninstalled and re-installed Omniplan on both my MBP and my iPad. I've reset and tested the account link several times. I went on my iPad to confirm that no file was present on the server. Nothing. Nada. Zip. Zilch.

Help! I don't want to use MS Project, but I really don't do Windows. If I can't sync to my iPad the extra effort to import and/or build a project plan in Omniplan isn't there.
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2013-05-13 at 3.33.53 PM.png
Views:	1359
Size:	33.9 KB
ID:	2843   Click image for larger version

Name:	Screen Shot 2013-05-13 at 3.34.21 PM.png
Views:	1392
Size:	28.1 KB
ID:	2844  
Sorry for the trouble! If you contact support, we'll be happy to help.

(We browse the forums when we're able and our other duties are complete, but we can't guarantee that someone from a particular team will see a given post. Apologies, but I'm not on the OmniPlan team, and I'm not sure what's causing this.)
I had exactly the same issue when i was trying out the Omni server for the first time, and tried to publish a newly created file. The error messages implied that Mac Omni plan thought the file was already on the server.

Very helpful response from Omni's Aaron:

Go to "File" > "Save As" and save a new copy of your project file. By doing this, you're creating a new OmniPlan file with a new unique ID. We use unique IDs to keep track of projects on the server so in the event that someone on your team accidentally renames their project file the sync should still work.

With the newly saved file open, try to publish that to the server. If the publishing is successful, have all of your colleagues download the new project from the server.
Which worked v nicely.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Omnisync Server API sgoldstein Syncing via Omni Sync Server 3 2013-04-05 07:19 AM
OmniPlan Server Repository: Publish Failure clifhirtle OmniPlan General 4 2012-09-17 06:03 AM
v1.8.1: Error on sync to server w/self-signed security cert. [Known issue: will fix.] 2do OmniFocus for iPhone 16 2010-12-15 06:11 PM
Unable to synchronize database with server. [Root Transaction Error] chad131 Other WebDAV 3 2009-08-23 09:01 AM
Internal Server Error mshalperin OmniWeb Bug Reports 3 2006-12-20 10:35 PM

All times are GMT -8. The time now is 07:10 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.