The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

"unable to read document" error Thread Tools Search this Thread Display Modes
so far LOVING the O-F. a very cool app, well done!

has anyone else encountered (and fixed!) this problem?

i overwrote the 5-19 version with the 5-20 and upon launching got 3 separate error windows like this below, then a window with just "alert"
Update to non-existant object with identifier 'he5L3mN1Lfh' found in transaction '{
"__self__" = "<XMLTransaction: 0x17d79c10>";
"_destinationIdentifier" = "76EE5005-C365-404F-95D4-41BB369BAFD4";
"_fileName" = "B31CCCD5-A4E4-48C5-9C97-8B36CB9C0FBE:76EE5005-C365-404F-95D4-41BB369BAFD4.xml";
"_sourceIdentifier" = "B31CCCD5-A4E4-48C5-9C97-8B36CB9C0FBE";
}' of '/Users/fogboy/Library/Application Support/OmniFocus/OmniFocus.ofocus'

my OS didn't crash but OF wouldn't do anything (nor would it quit, i had to force-quit). i sent all three error messages in via feedback. but when i tried to revert to the 5-19 version, same error. same today with the 5-20. should i replace one or more of the datafiles? any help much appreciated.

Last edited by fogboy; 2007-05-21 at 09:23 AM..
I don't have the app yet, but from the looks of that error message it appears your data file may be corrupted.

Try moving the file: '/Users/fogboy/Library/Application Support/OmniFocus/OmniFocus.ofocus' to your desktop and launching again. I'm assuming here that OmniFocus will try to create a fresh OmniFocus.ofocus file in your '/Users/fogboy/Library/Application Support/OmniFocus/' folder.

This hopefully will get the application working again, but of course all your data is in the (possibly corrupt) file you moved to the desktop.
yes! what actually worked was copying the latest known good backup file (several copies are in your ~/Documents/Omnifocus Backups/ folder - nice!) to the app support folder and launching from there (and then deleting the corrupted copy and renaming the copied one to remove the date). thanks!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
NOT APPLICABLE TO OMNIFOCUS 2: What to do about "Unable to open zip archive" error? timomni OmniFocus 1 for Mac 14 2013-10-02 04:51 AM
Error Message: Unable to read document, help please javimazzaf OmniFocus 1 for Mac 2 2012-10-19 01:40 PM
"Unable to Read Document" kevindaly iDisk/MobileMe/.Mac Syncing 3 2009-09-15 09:29 AM
"Unable to lock document. Another application had the OmniFocus document locked." drumshanbo OmniFocus 1 for Mac 7 2008-09-18 09:31 AM
"Unable to push calendars" error on iCal sync tomm iCal Sync 2 2007-09-01 06:42 AM

All times are GMT -8. The time now is 09:16 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.