The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Bonjour sync
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Can't get OmniFocus to sync with iPhone [SOLVED] Thread Tools Search this Thread Display Modes
Having found that the iPhone doesn't sync with my iCal tasks I came across OmniFocus which looks great - but it doesn't seem to want to sync between my Mac and iPhone.

I'm currently using the trial version on my Mac. I've set up a load of tasks and installed the iPhone app on my iPhone. I go into preferences in the Mac app and set up syncing via Bonjour and transmit the syncing signal. My iPhone sees this and I can select to sync with my Mac, but when I do so the main OmniFocus screen appears with a spinning disk at the bottom and I can't touch anything. This goes on seemingly indefinitely.

I appreciate that this isn't massively useful information in terms of getting this problem fixed - please let me know what information you'd like and I'll post it. Many thanks.
 
It is probably either of two things:

1. Your OmniFocus database is very large and it is just taking a long time to synch (in which case, just leave it until it has finished), or

2. Your firewall is blocking the outbound port for OmniFocus synching. There are a few threads on this somewhere...
 
Hi Jonathan,

I don't think it's either of those things. My OmniFocus database is pretty much brand new, with a few actions that I've added today. I left the iPhone app "spinning" overnight and by the morning nothing had happened.

I don't think it's the firewall either. The OS X firewall is set to allow OmniFocus through.

Any other thoughts?
 
Are you running OS X 10.4.x or OS X 10.5.x?
 
10.5.7
 
I'm really sorry about this! Are you on a 3GS, by any chance?

We're still working on figuring out the specifics, but since the new phone released, we've heard from some customers that are having problems like this. (From what we can see so far, the problem is specific to the new hardware, though it seems to affect both new customers and folks that migrated forward from older hardware.)

If that's the case, I know they're working on v1.5.1, but the best thing to do would be to email the support ninjas and let them know you're having this problem.

If you're not on the new phone, then we'll probably want to get the sync logs from your phone. That'll tell us exactly what's going on on the phone during the sync. The support ninjas can help you with that, as well.
 
I also have a 3GS and have exactly the same described problem. I have contacted the support ninjas and await a response.

If you resolve this issue or recieve any further information, can you keep me updated?

Cheers :)
 
I've had one reply from the support ninjas. It didn't help (I have, however, solved the problem - so read on!) but it might help you:

Quote:
- First, recycle the power on your wireless router, then try synching again. As basic as it sounds, this has been the #1 culprit with Bonjour synching issues.

- Reset synching on the desktop by going into the Sync pane of the Preferences menu, setting the sync method to "Nothing", then set it back to Bonjour.

- If you're running Tiger, try turning off the firewall, then sync OmniFocus. If that worked, I'll send you detailed instructions on how to sync with the firewall on; for now, we just want to get you up and running.

- If you're running Leopard, go into System Preferences>Security>Firewall, and make sure it's either set to allow all incoming connections, or add OmniFocus to the list of applications allowed access.

- On your desktop's network settings, make sure there aren't any proxy servers set up.

- Turn your iPhone off and back on.

- Try setting up and ad-hoc network for synching:

http://docs.info.apple.com/article.h...5/en/8339.html
As I said, none of this helped me - but I did get sync working very simply by using the WebDAV option which I was recommended by someone on Twitter (see http://twitter.com/deviantintegral/status/2317380340). I'd never used WebDAV before, but my brilliant web host (http://www.nethosted.co.uk) set it up pretty much automatically via the CPanel control panel software. Both Mac and iPhone sync to it, and it works perfectly - straight out of the box.

There does seem to be some kind of issue here with syncing via Bonjour and the 3GS (although one guy on Twitter said he had it working).
 
Right - well I think I will attempt to set up a WebDAV server since my website host also has cPanel.

The default path for the "Web Disk" seems to be in the public_html folder, did you leave yours in this location? I was worried about it being accessible to people veiwing my site.

Also, did you enter "http://www.yourdomain.com:2078/" into the OmniFocus sync settings? (ie. did you need to specify the port?), and did you need to copy any files to the webDAV server before you tried to sync?

I couldn't find a straightforward setup guide anywhere - so apologies for all the questions!

Hayley
 
Web Disk is the right way to go. I think it has to go in public_html to be viewable to the outside world - typing in the path of my Web Disk in a browser doesn't make it show up.

I used https://yourdomain.com:2078/ in the sync settings. I found that the port was necessary.

I didn't copy any files to the Web Disk - OmniFocus did all that.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to sync w/Bonjour since iPhone Omnifocus update [SOLVED: Blocked by router.] Nutty87th OmniFocus Syncing 7 2010-04-29 01:44 AM
Sync issues on iPhone 3GS hardware [SOLVED] Brian OmniFocus for iPhone 4 2009-06-28 06:26 AM
>20MB OmniFocus File (4779 items) [SOLVED: iPhone hadn't synced] DamonC OmniFocus 1 for Mac 5 2009-05-15 01:32 PM
[SOLVED] Help! OmniFocus hangs; won't complete sync; etc. DragonDave OmniFocus Syncing 18 2008-09-04 01:57 PM
SOLVED: iPhone OmniFocus refuses to sync with WebDAV, authentication issue lazerfire OmniFocus for iPhone 0 2008-08-02 04:14 PM


All times are GMT -8. The time now is 05:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.