The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Bonjour sync
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Bonjour sync trouble? Start here! - Configuring the Mac OS X Firewall. Thread Tools Search this Thread Display Modes
Mac OS X includes a security feature called a "Firewall" which can be used to block unwanted network communication with your computer. Configured correctly, the firewall can protect your computer from some of the less-savory aspects of life on the internet. (Identity theft, for example.)

Unfortunately, the firewall can also interfere with the network traffic that OmniFocus uses to sync via Bonjour. This forum post will walk you through the process of configuring your firewall to allow OmniFocus to sync, while still keeping the other protection the firewall provides intact.

(These steps don't account for other software which can block the sync - Little Snitch for example - which may be installed on the Mac. Wireless routers could also be interfering, if they have a built-in firewall.)

The steps you'll take to configure your firewall differ depending on what version of Mac OS X you have installed - the version that ships with 10.5 is somewhat simpler to configure. If you're still running 10.4, don't worry; just skip past the 10.5 instructions to find the steps you need.

Okay, here we go! If you have any questions, feel free to contact the support ninjas and we can help.

Configuring the firewall in 10.6:
  1. Quit OmniFocus.
  2. Open System Preferences, then click on Security, and switch to the Firewall tab.
  3. At the bottom right of the panel, press the Advanced... button. A sheet should slide out of the top of the panel.
  4. Make sure the "Block all incoming connections" box is unchecked.
  5. Press the small + button in the lower left of the panel.
  6. Another sheet should appear; navigate to and select your copy of OmniFocus, then press the Add button.
  7. OmniFocus should now appear in the large list area in the center of the panel. Make sure the pop-up to the right of OmniFocus is set to Allow incoming connections. Ensure that "Web Sharing" is enabled. Ensure "Block all incoming connections" and "Enable Stealth Mode" are both disabled.
  8. Assuming everything went as planned in the previous steps, you should be able to restart OmniFocus and complete the Bonjour setup process without the firewall interfering. (As always, contact the support ninjas if you need help.)

Additional note: It appears that the firewall in 10.6 is fairly picky about the circumstances in which it's willing to let OmniFocus sync, even when the application is on the approved list. It also appears that it caches a certain amount of information - if it decides to block us, the decision gets cached even if the settings change subsequently.

If you're having trouble getting through the firewall, you may want to try the following steps in this order:
  1. Ensure that OmniFocus is on the approved list.
  2. Turn the firewall off.
  3. Ensure Web Sharing is enabled.
  4. Turn the Firewall on.
  5. Launch OmniFocus.


Configuring the firewall in 10.5:
  1. Quit OmniFocus.
  2. Open System Preferences, then click on Security, and switch to the Firewall tab.
  3. At the top of the panel, select the Set access for specfic services and applications option.
  4. Press the small + button in the lower left of the panel.
  5. Use the new sheet that appears to navigate to and select your copy of OmniFocus, then press Add.
  6. OmniFocus should now appear in the large list area in the center of the panel. Make sure the pop-up to the right of OmniFocus is set to Allow incoming connections.
  7. Assuming everything went as planned in the previous steps, you should be able to restart OmniFocus and complete the Bonjour setup process without the firewall interfering. (As always, contact the support ninjas if you need help.)


Configuring the firewall in 10.4:
  1. Open Terminal.app (in your Utilities folder). Quit OmniFocus, if it is running.
  2. Paste this command into the window:
    Code:
    defaults write com.omnigroup.OmniFocus SyncServerPort -int 50042
  3. Hit return in the Terminal window to execute the command, then restart OmniFocus. (The command tells OmniFocus's bonjour server to run using a particular communication port.)
  4. The next step is to configure your 10.4 Firewall to allow connections to port 50042 from other machines. To do this, open up System Preferences, click on Sharing, then click on the Firewall tab.
  5. Click the New... button in the Firewall tab.
  6. Set the port name to Other.
  7. Add the port number you picked - 50042, unless you changed the command you entered in step 2.
  8. Optionally, set the description to "OmniFocus Sync Server".)
  9. Once that's all set up, click Okay. You should now see "OmniFocus Sync Server" in your "Allow" list, and it should be checked (allowing incoming connections).
  10. Assuming everything went as planned in the previous steps, you should be able to restart the Bonjour setup process without the firewall interfering. (As always, contact the support ninjas if you need help.)

Hope this helps!

Last edited by Brian; 2010-09-22 at 03:09 PM.. Reason: Add "disable stealth mode and block all" info.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sync with Bonjour only without firewall!!?? Flashracer Bonjour sync 3 2011-04-19 12:11 PM
Sync Stopped Working Using Bonjour [SOLVED: Firewall on Mac blocking sync] ajgilbert Bonjour sync 4 2009-06-21 09:46 AM
Bonjour Synch stuck at "preparing to synchronize" [Answer: Mac Firewall Preferences] tdonut Bonjour sync 3 2009-05-09 04:47 PM
[SOLVED: Firewall] I can not synchronise Iphone via Bonjour aladdinsane OmniFocus for iPhone 3 2009-02-18 05:50 AM
Bonjour Sync - Firewall questions bcapps Bonjour sync 14 2008-12-13 01:54 PM


All times are GMT -8. The time now is 06:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.