The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
"database on your iPhone is incompatible with the sync database" error message Thread Tools Search this Thread Display Modes
Quote:
Originally Posted by AndyThomas View Post
Hi

What was the fix? I get the same issue. I'm syncing between my MacBook Pro, Mac Pro, iPad and iPhone 4 (4.1)
Contact the support ninjas...http://www.omnigroup.com/support/
 
Have already done that, was hoping that somebody would share their experience given it sounds like there's a fix

I read this

"Thanks for the quick-fix, OmniFocus folks. I got help from the Tech Support Ninjas who got me set up to synch through the omni focus server instead of my local server, which solved the problem."

So it sounds like there's a general fix
 
All that guy did was set up sync with a different server, wiping away the old problem, just as replacing one of the databases would have done. It didn't do anything about fixing the root cause.

Contacting the ninjas is better because they can make sure that you really are applying the proper solution, and possibly ferret out some clues as to the underlying problem. If you're having sync problems, you should call them rather than waiting around for email.
 
Done

Did the simple thing and just gave up on MobileMe and went onto the OG server

Probably easier that way. Over time maybe the MobileMe issue will go, but I doubt there's much OG can do about it.

For anyone else seeing the same thing, just sign up here

http://www.omnigroup.com/sync

Took me about 2 mins to reconfigure all my devices

Thanks Ninjas!
 
I've been seeing this message for about a week now and I'm on the Omni Sync Server. I ended up deleting the folder on the server and starting over with syncing from my Macbook Air instance of OmniFocus. After several attempts from a complete 'do-ver' it's working now. I wonder if it has something to do with Perspective syncing... I just turned it back on, so I'll see how it goes. Never had a problem syncing before and I've been using the product since it was in beta....
 
1.9 appears to have fixed this problem for me. I disabled perspective syncing on the previous version and the problem disappeared. I've reenabled it on 1.9 and everything is working well.... Back to work....
 
I'm doing daily 3 way syncs with the all three client types and occasionally have this issue. But since I ALWAYS sync before I do any work in omnifocus and then after, I always know whether to keep the local or remote database so it's not a big issue.

(I sync using MobileMe and have iDisc syncing turned on)

Does anyone know:
a) How/Why omnifocus believes the databases are incompatible?
b) If there are any known scenarios that trigger it?

I have noticed that my iPhone clock can drift a few minutes a month and wondered if out of order timestamps might be a factor.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error message to replace database jappleseed Syncing via Omni Sync Server 1 2013-05-01 01:01 PM
Error message: Replace your database and start syncing Wordius OmniFocus 1 for Mac 1 2013-01-13 11:07 PM
incompatible with the sync database? kbs1138 OmniFocus for iPhone 0 2009-12-30 05:30 PM
OF for iPhone: Turning sync off/back on causes "No Root" error [FIXED-install v1.2.3] ajr OmniFocus Syncing 1 2009-04-29 03:33 PM
"Unable to synchronize database with server" error Tom Fort OmniFocus Syncing 3 2008-11-24 02:36 AM


All times are GMT -8. The time now is 11:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.