The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Tasks not showing up in context view from certain folders/projects Thread Tools Search this Thread Display Modes
I've searched the forum and have not found anyone with exactly this same problem. So I'm hoping someone can help. I have a problem whereby some tasks from some projects do not show up in the context view, even though they are active projects and active tasks. Whether I'm sorting by remaining or available or next action, it doesn't matter. They don't show up. The problem seems to relate to certain folders or projects that I have set up. I have experimented with setting up a new folder with the same exact task written, with the same qualities and then it shows up. Is it possible that a folder or project gets corrupted somehow and loses it's ability to sort into the various views? If folders or projects are getting corrupted this way, and I'm missing the full extents view of my task on a regular basis, then I'll lose confidence in OF's ability to accurately handle my task list needs.

Has anyone else had this same problem? And know of a fix?
 
It's possible that the database is getting somehow corrupted and that is why these actions aren't showing up, but it's also possible that you've simply configured something to hide them.

You can rebuild your database to check out the corruption theory. First, make a backup with File->Back Up Database... just so that you can show it to Omni if rebuilding the database solves your problem; maybe they'll be able to divine what was wrong. Then, do File->Rebuild Database... which will reconstruct the database cache and make sure that everything seems correct. If after doing that it still doesn't work, I would bet that the problem is not with the database but with, um, the operator :-)

I would bring up the view bar in context mode, and set it to All Contexts, Ungrouped, Project, Remaining, Any Duration, Any Flag. Make sure that both the Contexts and No Context bins are selected in the sidebar. Now search for the missing actions. Did they turn up?
 
Quote:
Originally Posted by whpalmer4 View Post
It's possible that the database is getting somehow corrupted and that is why these actions aren't showing up, but it's also possible that you've simply configured something to hide them.

You can rebuild your database to check out the corruption theory. First, make a backup with File->Back Up Database... just so that you can show it to Omni if rebuilding the database solves your problem; maybe they'll be able to divine what was wrong. Then, do File->Rebuild Database... which will reconstruct the database cache and make sure that everything seems correct. If after doing that it still doesn't work, I would bet that the problem is not with the database but with, um, the operator :-)

I would bring up the view bar in context mode, and set it to All Contexts, Ungrouped, Project, Remaining, Any Duration, Any Flag. Make sure that both the Contexts and No Context bins are selected in the sidebar. Now search for the missing actions. Did they turn up?
Thank you whpalmer 4. Unfortunately, I've tried both of your suggestions and neither corrected the problem Rebuilt the database. Still not showing in context view. Arranged the context view bar in the way you suggested... still not showing. I am sure that the folder/ project and task is active. And I am sure I have not overlooked it in the listing that is showing.

The thing about this is it has happened quite a bit before for me. Because of this, I am lossing faith in the ability for this program to keep track of my tasks.

I'm willing to consider that it may be my error. I'm just not seeing it at all. If it is my error, it's completely in my blindspot.
 
Guess what! I think I figured it out. I just wasn't seeing this.

The context view I was looking at was based on a custom project perspective in which not all of the active projects in view were highlighted. When I made sure they were all highlighted in the project view, it showed up in the context view.

The highlight aspect is something very subtle and I was just not seeing.

So in the end, it WAS user error. Now that I get the distinction of highlighting, I will be more aware of what I'm highlighting in the future.
 
Great! Glad you figured it out. It's worth remembering that the feature that gives OmniFocus so much of its power (IMO) is the ability to hide things from you :-)
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help Showing One Of Projects in Context View africannectar OmniFocus 1 for Mac 2 2013-05-08 01:35 PM
See only active projects' tasks in context view? sdmartin70 OmniFocus 1 for Mac 2 2011-04-26 11:33 AM
Seeing Folders in Context view freo73 OmniFocus for iPad 4 2011-04-13 12:02 AM
Projects Showing in Context View? ee99ee OmniFocus 1 for Mac 2 2011-01-17 07:09 AM
Groups, Projects, and SALs showing up in Context: No Context (1.8) omnibob OmniFocus 1 for Mac 2 2010-04-11 10:02 AM


All times are GMT -8. The time now is 02:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.