The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Database gets overwritten Thread Tools Search this Thread Display Modes
Hi guys,

I've experienced this issue a few times. I've tried to duplicate it and I can't. But it's been a very frustrating experience, and I wonder if anyone can advise as to how I should be expecting OF to work.

I'm running OF on a laptop, tower and iphone. They are kept in sync with webDAV. The issue seems to occur when I update the database in 2 different places when I don't have the opportunity to sync between the changes.

I will loose changes made (and some items entirely), when I do this.

For example, I recently was on an airplane, had no wifi, and made a TON of changes to my OF database on the laptop.

Then, on the fly and before I was able to sync the laptop, I captured a few things on the iphone, which then must have automatically synced itself.

When I finally had a chance to get my laptop on the wifi network, OF synced and I lost a ton of data. For example, I had maybe 40 items in the inbox, many of which had been translated into projects, etc. These tasks were no longer ANYWHERE in my database. Neither the inbox, or the projects I had created.

I've tried to re-create the issue as a test to see if I can identify EXACTLY what's going on, but actually I don't have this issue when I test it myself.

I've tried to be very diligent about not updating OF in 2 different places without syncing, but of course times come up when this is not possible... I've lost a lot of work a couple times, and I wonder if you guys can advise me in terms of:

Is this a bug? if so, is it specific to me?

Or is this just the way that OF works (IE, it can't really deal with not being constantly synced and update)

And finally: I'm currently syncing over webDAV to swissdisk.. any chance I could minimize these issues with another syncing method?

thanks!
 
Jakobox-

I'm really sorry for the trouble this is causing! I'm guessing at least part of what you're seeing is indeed caused when the same item is edited on more than one device.

For performance reasons - the iPhone is an amazing device, but it's still about a thousand times slower than a low-end desktop machine - conflicting edits to the same item are resolved on a per-item basis, not a per-field basis. (Doing the latter would cause syncs to take much, much longer than folks have told us they want to wait.)

What does this mean? If you sync two devices, then edit an action on both machines - change the note on one machine and the start date on the other - and then sync both machines again, you're not going to see each machine get the change from the other machine. You're going to see one or the other change win out over the other - specifically, you're going to see the change that happened most recently win out over the earlier one.

However, what you saw happen here doesn't quite match what I'm describing here. The 40 inbox items, for example, couldn't have been edited on both devices.

Just to be sure they're gone, on your Mac, can you please bring up the "All Items" perspective, then use the toolbar search field to look for them by name? My hope here is that the items were re-filed but not actually removed from the database.

If that doesn't turn out to be the case, please contact the support ninjas so we can look at your sync database and see if we can determine what's going on.

Last edited by Brian; 2010-04-07 at 10:15 AM.. Reason: Brian forgot that questions use "?" rather than "." :-)
 
Thanks Brian, for the response.

I tried to duplicate the problem again so I could test what you mentioned (IE see if I can find any lost items with the "all items" perspective)

However, part of the frustrating thing with this issue is that I'm not able to consistently replicate it.

I understand what you said about changes not being able to be merged together, but I don't think that's what's affecting me here. It's more like my database is being reverted to an older version.

Another clue: I woke up this morning to find that my database had more or less reverted itself to an earlier version (IE the state it was at about noon yesterday) once again. (frustrating!) When I tried to sync, I got the message

unrecognized date string for transaction. Expected a date string of 14 characters (YYYYMMDDHHMMSS), but got ""

Does that mean anything?
 
Quote:
Originally Posted by jakobox View Post
Does that mean anything?
Yeah, I'm pretty sure it means "contact support ninjas ASAP".

-Dennis
 
Quote:
Originally Posted by jakobox View Post
I'm running OF on a laptop, tower and iphone. They are kept in sync with webDAV. The issue seems to occur when I update the database in 2 different places when I don't have the opportunity to sync between the changes.

Is this a bug? if so, is it specific to me?

Or is this just the way that OF works (IE, it can't really deal with not being constantly synced and update)
To be clear: OmniFocus is designed to let you edit your database on multiple devices even when they're wildly out of sync. Edits to separate items (and new items are always separate) should always be preserved when synchronizing.

So, no, what you're seeing definitely isn't "just the way OmniFocus works"; it sounds like some other issue is coming into play here, where the changes (or "transactions" in database-speak) from one of your devices have somehow been mangled*(possibly by your sync server?). That "unrecognized date string for transaction" error is particularly worrisome, since OmniFocus always writes its transaction dates in the same format (which should always be recognized). If we start by trying to track that down we might get some insight into where the rest of your data has gone.

So, as suggested, the best way to proceed would be to contact our support ninjas, either by email at omnifocus@omnigroup.com or by telephone at 1-800-315-6664 (weekdays 10am to 5pm Pacific time).
 
One thing it may be worth triple-checking is that the copies of OmniFocus on your various devices are all up to date. (Maybe there's more than one copy of OmniFocus on one of your Macs and an old one gets launched occasionally?)

I don't have any hard evidence to go on, but the symptoms you're describing are roughly similar to some problems that existed in earlier versions of OmniFocus. It's been several months since we got support mail about any of them in any significant quantity, though. Most of our customers aren't seeing this happen any more.

Current release of OmniFocus (at the time of this writing; forum posts have a long lifespan) is 1.7.5, which you can grab on this page.

Current release of the iPhone app (check the bottom of the Settings screen) is 1.6.1.
 
Thanks everyone for all the advice. I'm going to give support a shout on Monday (so I can do it via phone). And I'll let you know if they can work it out.

Brian, thanks for the suggestion. I am actually away from my office and the mac tower at the moment (on the road).. but I'm pretty sure that version is up to date, and I'm certain that my laptop and iphone versions are up to date. I will double check on that as soon as I'm back home.
 
I just spoke with tech support on the phone.

It sounded like this is an issue that they've never really run into before. We tried some troubleshooting steps, which was basically to export and re-import the database, and to switch from Swiss Disk to MobileMe for the server.

Crossing my fingers that this fixes things up.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set up a new database? lorew OmniFocus 1 for Mac 4 2011-06-22 10:20 AM
"database on your iPhone is incompatible with the sync database" error message kevinwest66 OmniFocus Syncing 36 2011-05-08 03:32 PM
Shared bookmarks overwritten without prompt Forrest OmniWeb Bug Reports 0 2009-11-19 01:55 PM
Why is my database so big? wdiadamo OmniFocus 1 for Mac 4 2009-01-07 08:59 AM
How big is too big for a database? malisa OmniFocus Syncing 6 2008-09-21 10:02 PM


All times are GMT -8. The time now is 12:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.