The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Problems with Font Smoothing Thread Tools Search this Thread Display Modes
I have used Omnigraffle 2.0 for a long time, and I finally got around to trying the 4.0 demo. While I appreciate the many improvements that were made, I am having a problem with blurry text. Text seems to render correctly only when selected for editing. This problem exists both with files created in 2.0 or in 4.0, and does not occur if opened in 2.0. Has anyone else experienced a problem with antialiasing or font smoothing in 4.0?

BTW, I played with OS X's font smoothing settings with no luck. I am using a MacBook Pro with a 15" screen. The font I am having trouble with is Helvetica Neue, any point size from 12 to 20.
 
It is a known but unavoidable issue - Pages also suffers the same problem and it is due to the OS and a trade off between performance and display. There was an article about 6 months ago that described the reasons for it, but I've forgotten the site and link. Try searching Google for Pages and anti-aliasing and seeing what you come up with (never mind - here it is).

Note, if you export the file, you will see that the anti-aliasing is fine.
 
JKT:

I appreciate your reply. I actually saw that article while researching this issue. While I found it interesting, I wonder why this problem is unique to version 4.0?

The export suggestion does work (thanks), but I'll stay with 2.0 for now.
 
At a guess, we optimized drawing somewhere between 2.0 and 4.0.
 
I believe that the font rendering problem has been around since v3.

I could live with it, if it were a display-only problem, but the worst part is that text is rendered poorly in exported raster formats as well -- my 'beautiful OmniGraffle diagrams'(tm) are spoilt by shoddy looking text. :(
 
To be clear, is the text that looks "shoddy" labels and such without a fill color?

If so, is it possible for your situation to turn on a fill color and does that fix the text for you?
 
Yes, turning on a fill color does smooth out the fonts. This solution solves this problem for me in most cases. However, I do have a few areas where I have placed text over subtle, linear blended fills, and in these cases the text background fill is somewhat perceptible. Is there no chance that this issue can be addressed in a later release?
 
I can't speak to whether the issue will be addressed in the future as I'm not on the Graffle team--just trying to help you out with this particular problem and understand the issue myself. To make sure your request is filed appropriately, use "Send Feedback" from the "Help" menu.

I'm not sure if the general problem can be solved since Graffle can be used to generate images with a transparent background and text over a transparent background will always have this issue.

I presume when we go to print, and we don't have shadows or other such situations we might be able to draw the text over the existing background.

You originally mentioned playing with the Font smoothing style, but I'm wondering if you tried setting it to CRT. Also, I think you have to restart Graffle for it to take effect.
 
Len:

You have a great ability to find possible solutions to this problem! Changing the Font Smoothing style to "CRT" in System Preferences does significantly help the text rendering problem (after a restart of Graffle) for text without fills. However, although fonts appear much better, the CRT setting does not provide for text as sharp as it is with a filled background and Font Smoothing set to "Medium". This is the solution that I will use once I upgrade to 4.0.

Thank you very much for all of your help.
 
Glad I could help. Don't forget to send feedback to our support team as well so that this issue can be properly tracked.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting screen font vs. print/export font [A: text zoom coming in OO4.] gmiddleton OmniOutliner 3 for Mac 26 2012-05-06 03:56 AM
Font size bas42 OmniFocus 1 for Mac 1 2008-03-28 11:21 PM
application font jstarrantino OmniWeb General 1 2006-08-22 10:15 PM
Why can't I use any font? stan OmniOutliner 3 for Mac 6 2006-07-17 04:55 AM


All times are GMT -8. The time now is 12:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.