The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
NOT APPLICABLE TO OMNIFOCUS 2: What to do about "Unable to open zip archive" error? Thread Tools Search this Thread Display Modes
Day two on Omni Focus and I'm Omni-Up-The-Creek. Spent hours yeasterday getting all my "brain dump" organized. Synced with my iphone and it worked great. Today I can't open the application and get this error message

The unzip library failed to open /Users/timwalsh/Library/Application Support/OmniFocus/OmniFocus.ofocus/20090808141324=lULxKsQYrJy+c9uPR3rlYDi.zip.

Anyone have any idea?
 
Quote:
Originally Posted by timomni View Post
Day two on Omni Focus and I'm Omni-Up-The-Creek. Spent hours yeasterday getting all my "brain dump" organized. Synced with my iphone and it worked great. Today I can't open the application and get this error message

The unzip library failed to open /Users/timwalsh/Library/Application Support/OmniFocus/OmniFocus.ofocus/20090808141324=lULxKsQYrJy+c9uPR3rlYDi.zip.

Anyone have any idea?
Call or email the Omni support ninjas. They are amazingly helpful and will get you up and running again in no time.

normal support email: omnifocus@omnigroup.com
urgent support email: urgent@omnigroup.com
contact phone available here

Good luck!
__________________
Cheers,

Curt
 
I got the same, although oddly only one mac, not both. I got the following reply from the ninjas:

- Log into your iDisk, and clear it of any OmniFocus files (perhaps moving them to the Desktop in case you need them later)

- Run a sync on the "good" copy of OmniFocus (that is, the Mac that isn't returning an error when you try to launch OmniFocus). This should copy that copy of the database onto your iDisk.

- Quit OmniFocus on the Mac that won't open the database.

- Navigate to ~/Library/Application Support/, and move the file OmniFocus.ofocus aside to the Desktop.

- Now, relaunch OmniFocus- you'll notice that it opens with the blank "welcome" document.

- Run a sync- if it asks you to pick the local or server copy, pick the server. This should copy the database on your sync server to the Mac.

- Relaunch OmniFocus, and you shouldn't see that error message again.

***************
can't comment if this worked as didn't follow instructions accurately. Uninstalled and re-installed OF in the meantime. Initially has worked.

Last edited by Brian; 2009-08-10 at 05:03 PM.. Reason: remove instructions on editing the contents of database. Concerned folks will damage their data.
 
I've been unable to open my database on my main working Mac all day. I'm getting the error message 'Unable to open zip archive, The unzip failed to open'.

Fortunately, I've been able to open a copy on my laptop. Does anyone know how to solve this?

Many thanks,
Leanda
 
I'd suggest emailing the support ninjas at omnifocus@omnigroup.com (or, if you need a faster response, urgent@omnigroup.com).
__________________
Cheers,

Curt
 
Quote:
Originally Posted by curt.clifton View Post
I'd suggest emailing the support ninjas at omnifocus@omnigroup.com (or, if you need a faster response, urgent@omnigroup.com).
Thanks, have done and I'm running through the steps to fix.
 
Code:
NOTE: these steps were valid at the time they were posted, but as of 
the time of this writing (Nov. 2017) google is still presenting them for certain 
searches. They will not help customers using current releases of 
OmniFocus resolve this problem! Contact our Support Humans for help 
instead.

Posting the response we sent Leanda in case other folks run across this problem in the future.

If you're syncing OmniFocus with another Mac, or an iPhone/iPod, you can resolve the issue by doing the following on the machine that's presenting the error. If you're not syncing, we can still help; just skip down to the bottom of this post.

To resolve the problem on a machine that's being synced, do the following:
  1. Quit OmniFocus.
  2. Select "Home" from the "Go" menu in the Finder. A new window will appear.
  3. Starting in the Home folder selected in the new window, open "Library", then "Application Support", and finally the "OmniFocus" folder.
  4. You should see a file named "OmniFocus" or "OmniFocus.ofocus". Please rename it to "OLD-OmniFocus.ofocus".
  5. Launch OmniFocus; it should open the blank "welcome" database.
  6. Go ahead and sync OmniFocus. When it asks you to pick the "local" or "server" copy of the database, choose Server.
  7. Once that sync goes through, go ahead and relaunch OmniFocus.

If OmniFocus launches without error, you should be all set. We have plans to add code that does all this automatically, but it's not in place yet - apologies for the inconvenience this caused.

If you're not syncing, or if that didn't help, please contact the support ninjas after doing the following.
  1. Select Go -> Home from the menu bar in the Finder.
  2. Switch to the "Documents" folder.
  3. Open the "OmniFocus Backups" folder.
  4. Double-click the most recently-created backup in that folder. If it presents the same error message, close the window and repeat with the previous backup. Keep opening backups until you reach one that opens without any error messages.
  5. Send the backup you opened and your "real" OmniFocus database to the support ninjas. We'll repair the problem. Your database is located here:
    <your home folder>/Library/Application Support/OmniFocus

We'll use the files to get things sorted out ASAP. Apologies for the trouble.

Last edited by Brian; 2017-11-27 at 11:13 AM..
 
Back up and running. Followed Brian's instructions but I also had to delete my database from MobileMe and re-sync with the good version before I could get the sync to go through on the corrupt version.

Many thanks for the help.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Unable To Save Change" Error monooso OmniFocus 1 for Mac 2 2011-11-21 06:00 AM
How to make a "No Due Date" perspective? [Answered: see thread] kman42 OmniFocus 1 for Mac 1 2010-04-06 03:56 PM
Error: "Unable to load preferences" vplane9 OmniFocus Syncing 1 2009-03-20 03:33 PM
"Unable to synchronize database with server" error Tom Fort OmniFocus Syncing 3 2008-11-24 02:36 AM
"Unable to push calendars" error on iCal sync tomm iCal Sync 2 2007-09-01 06:42 AM


All times are GMT -8. The time now is 01:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.