The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Omni Focus on iPhone 3G crashed Thread Tools Search this Thread Display Modes
Help. My Omni Focus on iPhone 3G crashed and doesn't start up any more. How can I delete and reinstall OmniFocus or ist there any workaround to solve this problem?

regards
Axel
 
I'm having the same problem. The first few times it crashed, rebooting the phone made it run again for a short time. Now it will not start at all. I get the "loading" progress bar, and once it gets to about 1/4 the app just closes out.
 
I had this problem too- I went into application download overdrive, trying out a few paid apps and lots of free apps- very few of the downloaded apps would work- just show the splash screen and crash.

I removed the free apps from itunes, resync'd and it started working. Other people have had luck re-authorizing their computer

Hope this helps,

Simon


http://discussions.apple.com/thread....535&tstart=510

http://discussions.apple.com/thread....878&tstart=480
 
I've had this problem twice since I purchased the app. yesterday: when I launch the app., it freezes during the "Loading..." screen and then crashes. Each time, the only way I've been able to fix it is to delete the program from the iPhone and redownload it from the iTunes store, then resync my data base to the Mac app.

I'm not, though, experiencing crashes with my other iPhone apps., as the post above suggests.

I'm using an First Gen iPhone, not a 3G iPhone.
 
I've had problems with apps closing right after opening before, but this is different. This runs for a short time then fails while it is trying to get my data. When I have the other problem the apps close before even being displayed. And in THAT case there's one trick that always fixes it--loading another app. If I load one more app, all the others start working again. This is fully repeatable. So even removing/re-adding an app works, or just loading an additional one.

However, this is not the same problem I'm having with Omni Focus, and that trick doesn't work. Authorize didn't help. Removing Focus and re-synchronizing did fix the problem, but I fear it will return.
 
If anyone is still having trouble like this, please contact our tech support ninjas as soon as possible at omnifocus-iphone@omnigroup.com. We're here to help!
 
Quote:
Originally Posted by calvarez View Post
I'm having the same problem. The first few times it crashed, rebooting the phone made it run again for a short time. Now it will not start at all. I get the "loading" progress bar, and once it gets to about 1/4 the app just closes out.
For the most part, this appears to be happening to folks that have more actions in their database than the iPhone can hold in memory at once. Once memory runs out, the phone shuts the app down.

In OmniFocus 1.1, we added a new "Archive Old Data..." item under the File menu. It will move older actions over to a separate database file that isn't synced with your phone. This way, you have access to your older actions when you need to refer to them back on your desktop, but your phone doesn't run out of memory.

In general, we'd recommend trying to keep the number of actions on your phone down below a thousand.

So, the procedure here would be:
  • Back up database on desktop
  • Archive data on desktop
  • Synch on desktop
  • Synch on phone

Does that help the crashes?
 
Just to let you know - me too, although I have emailed the ninjas...

I hit the icon on my iphone front page, the loading screen appears, I get maybe 20% of the way down the load bar and it crashes back to the desktop.

After effectively forcing me into a .me account with the sync issues, I am even less impressed with this latest bug.
 
As a data point, I think I may be in the "for the least part" category then. I should currently have about 300 total in my database (75 remaining, the balance completed). My experience was that the iPhone app went into a cycle of crashing out during database load after a sequence of rapid syncs (using webDAV) between the desktop app and the iPhone app. I would speculate that some form of terminal database corruption occurred.

Let me take the opportunity to congratulate you guys on a really great app. Your recent award was very well deserved. I certainly appreciate how difficult this type of synchronization is and look forward to seeing the wrinkles ironed out.
 
Omni Focus has crashed on my iPhone as well. Same symptoms as others have reported. I also noted that Safari went down at the same time - perhaps due to memory related issues with Focus? Specifically the app would launch, but it was not possible to interact with the webpage or controls. Rebooting solved the Safari crash, but not Focus. Like others have mentioned I deleted the app and reinstalled. I have also followed the advice to archive old actions. Fingers crossed.

Could the number of actions Focus can keep in memory be related to how many of the standard applications (like Safari) are in use? I had 8 pages open in Safari when the two apps failed.

Will we have to keep archiving old data, or can this process be made automatic?
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Updated iPhone to 5.0, Omni-focus GONE! dryan75 OmniFocus for iPhone 2 2011-10-17 05:17 AM
IPhone SDK and Omni Focus Lite? soupy OmniFocus 1 for Mac 2 2008-03-07 10:55 AM
OmniWeb crashed and stays crashed? consiglieri OmniWeb General 1 2008-03-06 07:48 AM
Omni Focus' integration with Omni Outliner. Tinchohs OmniFocus 1 for Mac 3 2007-09-10 04:24 PM


All times are GMT -8. The time now is 01:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.