The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Bonjour sync
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
How to replace OS X OF with iPhone db? Thread Tools Search this Thread Display Modes
I created an archive file, and didn't want anything moved by OF (I prefer to manually move items), so I choose archive before 1/1/06 (earlier than any data I have), but ended up with actions put in the archive anyway. Unfortunately I don't have a recent enough backup on my computer, and don't want to have to go through the painstaking process of manually moving things from the archive into just the right location. I have a current copy of my OF in my iPhone -- how can I overwrite the OS X OF with that?

Bob

(sent in as a ticket just now)
 
Assuming you are syncing via MobileMe, the easiest approach would be to remove the database from the MobileMe server with the Finder (rename it rather than deleting it, just to be safe), then force the iPhone to do a sync. After that, the desktop copy should detect that the server copy is newer and offer to replace your local copy and start syncing. Take it up on its offer.
 
I'm Bonjour syncing.
 
Troublemaker :)

It's a little trickier with Bonjour. Quit OmniFocus on both devices (hopefully it hasn't gotten a chance to step on the good copy of the database on the iPhone!). Then go to the Library/Application Support/OmniFocus folder in your home directory. Rename OmniFocus.ofocus to Old OmniFocus.ofocus. Now connect to the Syncronization Data/Documents folder in that directory and do the same with the copy of OmniFocus.ofocus you find there. Having done this, you can restart OmniFocus on the desktop. It will give you the default new database, which is okay. Now launch OmniFocus on the iPhone and force a sync. It will notice that the two databases don't match and ask whether you want to keep the device database or the sync database. You want to be sure to answer Keep Device Database! Now have the desktop do a sync, which should get you the "Replace database and start syncing?" dialog. Answer affirmatively and you should be done.

Might not be a bad idea to plug your iPhone in with the cable and do a sync/backup before this whole procedure, just as a bit of insurance.
 
whpalmer4,

I humbly submit that I did not see (did not navigate to) the actual relevant backups. Your post is *most* appreciated, though!

The saga continues...

I'm having a hard time making heads and tails of this. I'm using OF (OS X) (and iPhone OF, but I don't think that has any bearing).

At 6:17PM, 9/15/2009, I created my archive file (as explained in my original email).

When I chose File > Revert to Database Backup…, I was presented with a dialog showing:

~/Application Support/OmniFocus/

I didn't see any relevant backups there. Turns out, I think, that folder is just the last one I visited from that dialog, so it was remembered.

Later, I discovered that my backups are in ~/Documents/OmniFocus Backups

OK, good enough. Then I chose "Revert to Database Backup…" and selected:

OmniFocus 2009-09-15 181757 before archive.ofocus-backup (which was 5:58pm 9/15/2009)

… which is just prior to creating the archive.

However, the resultant OF file, which has a project "Studio is built", does *not* contain any completed actions (which show up in my archive file), *except* one completed Aug 4, 2009 1:34 PM. NOTE: in my current OF file, with the project selected, I have "Any Status" selected, so I'm not filtering out completed actions (and "Any Duration" and "Any Flag State").

I then reverted to the 5:58pm file ("OmniFocus 2009-09-15 175852.ofocus-backup") *not* marked as "before archive.ofocus-backup"; same results.

I then reverted to today's (9/15/2009) 4:58am database: "OmniFocus 2009-09-15 045827.ofocus-backup", yet still, the completed tasks are not showing. Since I had no archive file at all, at that point in time, the only thing that I can think of is that, perhaps, there is some kind of automatic archiving going on -- immediately upon opening an older file, pre-archive. When I choose "Move Old Data to Archive" (just to see what's going on; not executing the archiving), the date shown is: "8/1/09". But I would expect, that when restoring a copy of my OF db that had never been archived, that all items would appear. Any help is greatly appreciated.

Bob

p.s. ticket to Omni updated

Last edited by omnibob; 2009-09-15 at 08:04 PM..
 
At this point, I'm not confident that I fully understand the situation you're in, so rather than risk making it worse, I'm going to say you should call up Omni tomorrow at 10AM west coast time (1-800-315-6664) and have them walk you through it. Sorry I can't be of more help!
 
OK, I think I've gotten to the heart of the matter (sorry, Don Henley ;) ).

After restoring, there is a second dialog which I glossed over and clicked OK, which replaces the database with the 'server' version. When I later clicked 'cancel', I appeared to end up with the correct data. Anyone thinking otherwise speak now, or forever hold your peace!

Bob

p.s. Thanks, whpalmer4, for the great advise and encouragement!

Last edited by omnibob; 2009-09-16 at 08:16 AM..
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Find and Replace only in selection? steve OmniOutliner 3 for Mac 6 2011-10-25 09:51 AM
Fun with Find and Replace steve OmniFocus 1 for Mac 7 2010-08-06 03:36 PM
Replace database with one from iPhone MichaelG OmniFocus for iPhone 2 2010-01-10 06:55 PM
Search... and replace!? CheepnisAroma OmniWeb General 3 2006-07-31 06:30 PM
Search and replace Manticore OmniOutliner 3 for Mac 3 2006-05-20 02:52 AM


All times are GMT -8. The time now is 06:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.