The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Impossible to set due date/time Thread Tools Search this Thread Display Modes
I've been having problems from time to time with setting the due date/time for actions, and have really never understood why it has worked sometimes, and sometimes not.

For the past weeks, it has been impossible, though. I enter the new date/time, and it just doesn't "stick". If I click on another task, and then back to the task I just set, it doesn't have a due date/time any more.
 
What version of the software and Mac OS are you running? At one time there was a problem with the date-picker calendar where the date would be lost unless you pressed the "return" or "enter" key. I can't seem to reproduce it now in OF 1.6.1 on Mac OS 10.5.7. Also, pressing the "esc" key after clicking a date in the date-picker will cancel the date entry.
__________________
Cheers,

Curt
 
Quote:
Originally Posted by moz View Post
For the past weeks, it has been impossible, though. I enter the new date/time, and it just doesn't "stick". If I click on another task, and then back to the task I just set, it doesn't have a due date/time any more.
Where are you entering date/time? Is this via the inspector, the quick entry window, the main window? Are you typing in the date/time, or using the calendar widget? Can you capture a screen shot of your window just before you click on another task?
 
I'm also using 1.6.1 on 10.5.7.

I'm using the separate side window/inspector I guess. Attaching screen shot.

The weird thing is, that it works now. And when I'm restarting, it keeps on working. And then I'll most certainly have days when it doesn't work even after restarts/reboots. Man...

And I'm always finishing the input like I am now - by pressing return. And now it will work for a day or two :)

I've used Omnifocus for like half a year, and I dont think this started until 1.6.1.
Attached Thumbnails
Click image for larger version

Name:	Bild 2.jpg
Views:	290
Size:	20.4 KB
ID:	932  
 
How very strange. You should definitely contact the support ninjas via Help->Send Feedback or email to omnifocus@omnigroup.com to see what they have to say. Maybe one of the developers might have an idea as to what might be going on in your case.
 
Quote:
Originally Posted by moz View Post
I've been having problems from time to time with setting the due date/time for actions, and have really never understood why it has worked sometimes, and sometimes not.

For the past weeks, it has been impossible, though. I enter the new date/time, and it just doesn't "stick". If I click on another task, and then back to the task I just set, it doesn't have a due date/time any more.
I just joined these forums for the same reason. It works fine sometimes, others not. Right now I can't set any dates on the desktop version (even hitting "enter" doesn't "lock" the date), but I can change other aspects (such as the context) by using the inspector.

Works great on the iPhone, though!
 
So we can try to narrow down what's going on here - are folks having trouble typing in the dates, or selecting them with the mouse? I'm assuming the latter, but wanted to double-check.
 
Quote:
Originally Posted by Brian View Post
So we can try to narrow down what's going on here - are folks having trouble typing in the dates, or selecting them with the mouse? I'm assuming the latter, but wanted to double-check.
The strange thing is neither. As far as I can tell, it just doesn't take. I can put in the due date (either enter it myself or select it from the calendar), hit enter and all of that, but when I click off the action it acts like the date was never entered. Everything else is fine (so if I change the context, that stays), but the date won't keep.
 
Just had a thought that this may mean that what's being entered into those fields is something that the short date formatter in system preferences can't understand.

To check what your short date formatter expects to see, do the following:
Open System Preferences and switch to the International pane.
Open the Formats tab.
Press the Customize button next to "Dates".
Set the "Show" pop-up at the top of the sheet that appears to "Short".

(You can use a similar process to see what your Time formatter settings are.)
 
I came across this thread when trying to find out why I can't enter a time for a due date.

I'm using the quick enter dialogue. I've been able to specify a due date without a problem - it always works. But just recently I tried entering a due date AND time and it doesn't work.

I use the calendar picker, I select the date and enter the time. When I press enter nothing is saved to the due date field.

I'm using version 1.6.1 (v77.16.6.0.112316) of OF. I'm on 10.5.7 of OSX.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
viewing Due Date and Time... csonni OmniFocus for iPad 7 2012-10-04 11:55 AM
Due Date with no time spiliog OmniFocus 1 for Mac 6 2011-08-26 12:09 AM
Due Date without a Time? snowblink OmniFocus for iPad 5 2011-01-13 03:48 PM
Impossible Repeating Problem? rh26 OmniFocus 1 for Mac 2 2010-08-26 05:02 PM
Impossible to quit Omnifocus mschwarz OmniFocus 1 for Mac 7 2009-01-21 07:10 AM


All times are GMT -8. The time now is 09:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.