The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
iPhone wanted to sync with webdav, now everything is a mess Thread Tools Search this Thread Display Modes
Hello,

I just came home from school and was going to sync OmniFocus on my iPhone and my Macbook. The last days we've had a problem with our internet provider, so I've used the iPhone for internet tethering. For that reason, I haven't switched on wi-fi on neither the phone nor the computer for a couple of days because then I wouldn't be able to use the internet at all. So, it was some time since I synced them.

Yesterday, I had about 30 actions in my inbox which I processed so the inbox was empty. And when I came home today I had 15-20 actions in the inbox on my phone.

When I tried syncing, it said something containing "root server, do you want to continue anyway?". I don't remember all of it and it seems I can't reproduce it. Then it asked me to log on to a syncing site which I don't remember doing before (but might have done). It said something with webdav, which I'm not using. I've only synced over Bonjour before and it's worked well 90% of the times. I tried not to log onto the website and do it as I usually do (i.e., open OF on the phone and let it sync automatically). That didn't work, so in the end I put in a password and it started syncing. However, I ended up with all of the 30 actions I'd previously worked through + the stuff from the phone in my inbox. So now I have 50 items in my inbox, of which I've processed 30. I know I did, I can see that I sent some mails connected to those tasks and did other things as well. I tried to back up OF on my Macbook with a version I had yesterday night (when I had processed those items) but it didn't work and I'm still stuck with the 50 in the inbox.

The only thing I can remember changing from last time I synced was the Computer name. Because we had problems with the internet, I tried sharing the internet on my phone from my computer to my flatmates' computers (didn't work though, but that's another story...). For some reasons, I changed the name from "Henric Fröberg's Computer" to "Henric Fröberg". The last one was the one I had when I tried to sync the first time this afternoon. Then I changed it back, hoping it would somehow work, but it didn't.

What has happened here, and is there any way to solve it? I'd rather not go through the inbox again, knowing that I already did it once...
 
Henric, I'm really sorry for the trouble this is causing! I don't think we have enough information yet to determine exactly what happened - it sounds like some combination of changes in System Preferences (changing the sharing name of the Mac) and in OmniFocus' preferences are involved.

If you contact the support ninjas, we'll be happy to investigate this further with you, though!

The good news is that OmniFocus for Mac backs up your data periodically - you mentioned you tried to revert to a backup and it didn't work, but just in case you tried some other sequence of steps, here's what I would recommend:
  1. Turn off sync in OmniFocus' for iPhone's settings for the time being, to prevent a recurrence.
  2. On your Mac, open this folder:
    <your home folder>/Library/Documents/OmniFocus Backups/
  3. Select View -> As List from the menu bar.
  4. Click the top of the "Date Modified" header until the items that were modified most recently are at the top of the window.
  5. You can now double-click these backups to open them alongside your "real" data. You want to work backwards through the backups until you find the most recent one that was before the bad sync.
  6. Once you locate that backup, make a note of the file name - it's at the top of the window.
  7. Next, select File -> Revert to Database Backup... from OmniFocus' File menu.
  8. A new window will appear. Select the backup file you noted in the previous step in the file list. Once you press the "Open" button, OmniFocus will roll your data back to the state it was in when that backup was made.

It's important to note that any changes made after that backup will be lost, so be careful, but that should get you back to the state you were in before the bad sync. Contact our support ninjas at that point and we can help sort out what happened here.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sync iphone webdav OK, no desktop love though... akh pugilist Other WebDAV 0 2009-02-24 05:54 PM
WebDav Sync works between machines but not iPhone v.bampton Other WebDAV 1 2008-09-17 05:19 AM
Getting wrong data on iPhone after sync (cPanel; WebDAV) omnibob Other WebDAV 2 2008-07-28 07:49 PM
A2 Hosting settings with iPhone webdav sync coppethall Other WebDAV 5 2008-07-22 08:03 PM
iPhone Webdav sync with non-standard port jtynefield Other WebDAV 1 2008-07-16 04:41 PM


All times are GMT -8. The time now is 05:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.