The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Copy-Paste Logic Thread Tools Search this Thread Display Modes
I've been using OG for years and there's one thing that bugs me no end. When I copy and paste from one layer to another or one canvas to another, the pasted element is always offset from the original position in both X and Y axes. And yet, every once in a while, it pastes it exactly in the same location, and that's when I go "Hallelujah"! But I have not been able to figure out the logic to make it do that.

I can understand offsetting if you're pasting in the same canvas/layer, but if I change layers or canvases it's more likely I want it in precisely the same location as it was in the other layer/canvas.

I've been very frustrated with this for a long time, I hope someone can tell me if there's a trick to getting it in the right place that I'm somehow executing once in a while without realizing? Or is it just unpredictable?

Thanks,
--pv
 
Huh! My experience is exactly the opposite (when I cut from one layer/canvas and paste into another, it almost always pastes in exactly the same location). But it is not perfect and some small percentage of the time, the paste location is offset X+1, Y+1 Minor Grid units (which is correct for pasting onto the same layer/canvas).

You're no clicking anywhere on the target layer/canvas,between the cut and the paste, are you ? That would direct the location of the paste. It is not a "trick" but you should not do that, if you want it pasted to the same location.

I use OG4.

Sorry, I do not have an answer.
 
Thanks for the response (even if you don't have an answer :-). I am being very careful to not click on the target layer/canvas, and just on the thumbnail in the left pane. And yet, I often (but not always) get the X+1, Y+1 offsets. I've learnt to do Shift and left arrow + up arrow immediately after pasting (while the pasted objects are still selected).

I'm on OG5, but this was also my experience with OG4.
 
Strange.

Ok, another thing to try. I have very precise drawings, and I use a standard: eg. basic templates that include settings for A4 (portrait and landscape) plus a grid (2cm Major and 10 Minor); ShowGrid and SnapToGrid. This allows me to render the same "look and feel" to my drawings, and to move objects from one drawing to another easily (without having to fiddle around with changing sizes, fitting into another Grid, etc). This may have a bearing on the behaviour of the cut-and-paste.

Are you using the same Grid and Grid settings across the Master and all Canvases ?

Also try (annoying workaround that I use for those infrequent times when it misplaces the paste). OG seems to be intelligent enough to correct itself. After the Paste (in the X+1, Y+1 or other incorrect location):
⌘z
⌘v
That smacks it in the head, and always (the second time) places it in the correct location.

Last edited by DerekAsirvadem; 2010-10-17 at 04:07 PM..
 
I do have the same Grid across all canvases.

And when I do the Undo and Re-paste, it offsets it even further (X+2, Y+2), and so on for each successive attempt. Sometimes if I go back, re-copy and then re-paste, it pastes it in the correct spot. But not always. Even more annoying than the offsetting is the unpredictability of it.

Thanks anyway for trying to help out...
--PV

Quote:
Originally Posted by DerekAsirvadem View Post
Strange.

Ok, another thing to try. I have very precise drawings, and I use a standard: eg. basic templates that include settings for A4 (portrait and landscape) plus a grid (2cm Major and 10 Minor); ShowGrid and SnapToGrid. This allows me to render the same "look and feel" to my drawings, and to move objects from one drawing to another easily (without having to fiddle around with changing sizes, fitting into another Grid, etc). This may have a bearing on the behaviour of the cut-and-paste.

Are you using the same Grid and Grid settings across the Master and all Canvases ?

Also try (annoying workaround that I use for those infrequent times when it misplaces the paste). OG seems to be intelligent enough to correct itself. After the Paste (in the X+1, Y+1 or other incorrect location):
⌘z
⌘v
That smacks it in the head, and always (the second time) places it in the correct location.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
cut/copy/paste regression analyticalbiochemist OmniFocus for iPhone 4 2011-03-13 07:32 PM
Copy/Paste into OmniOutliner eronel OmniFocus 1 for Mac 5 2011-03-01 03:24 AM
Copy/Paste with keyboard shhQuiet OmniGraffle for iPad 0 2010-11-09 02:02 PM
Can't copy and paste! UncleB OmniWeb General 0 2009-08-26 06:40 AM
Copy & paste action pvonk OmniFocus 1 for Mac 7 2007-10-26 10:01 PM


All times are GMT -8. The time now is 05:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.