The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Clipping Problem Thread Tools Search this Thread Display Modes
I'm using Chrome. But I tried in Pages, too.

I'm wanting to copy and quick entry. Won't work. I recorded control-option-space. Doesn't work.

Isn't it supposed to copy to the clipboard and then put in Omnifocus, or am I confused?
 
Sorry for the trouble here - there are a couple different things that could be going on here. First, try the steps in this thread.

There's some additional Chrome-specific info available here.
 
Quote:
Originally Posted by kevinplarson View Post
I'm using Chrome. But I tried in Pages, too.

I'm wanting to copy and quick entry. Won't work. I recorded control-option-space. Doesn't work.

Isn't it supposed to copy to the clipboard and then put in Omnifocus, or am I confused?
Perhaps you could be a bit more specific about exactly what you are doing. Pretend I can't see your fingers or screen :-) I think I know what you are doing, but can't be sure from your description.

There are two different places where you can record a key shortcut in OmniFocus: there's the clipping shortcut, and there's the quick entry shortcut. The quick entry shortcut (I use control-option-space) just brings up the quick entry window, but does not copy anything. The clipping shortcut (I use cmd-shift-, or as I think of it, cmd-<) copies the selected material into either the quick entry box or directly into your inbox, depending on your settings in the Clippings Preferences pane in OmniFocus.

"But why doesn't it work?", I hear you saying. Pages set ups cmd-< and cmd-> as zoom commands, and so intercepts the shortcut instead of allowing you to send the clipping off to OmniFocus (or OmniOutliner, in the case of cmd->). If you use a different keyboard shortcut not used by Pages (cmd-option-<, for example) Pages will allow the clipping service to be invoked.

Chrome is a different matter. It doesn't intercept the keyboard shortcut, but when you have something other than a URL in the address bar selected, it tells the Services code that no services apply, and so the clipping service isn't available. I don't know why it does that, or how to change its behavior. I think it is a Google bug, not an Omni bug, because if I visit the same page in Safari and select the same text, all sorts of services (not just Omni's) are available.
 
Well, I think I understand. So chrome doesn't work well, eh? I'm liking chrome because the Evernote clipper works SO well! Oh, well...

With Pages, does anyone know short-cuts well enough to know a good one?

I was trying to use control-space for quick entry and control-option-space for clipping, but that definitely doesn't work (for the latter).
 
Quote:
Originally Posted by kevinplarson View Post
I was trying to use control-space for quick entry and control-option-space for clipping, but that definitely doesn't work (for the latter).
I use control-option-space for quick entry, and a quick trial revealed that it works fine when Pages is the front-most application, so if you're having a problem using it in Pages, there must be something else going on. Does it work if you have a different application in front? Are you sure it recorded the shortcut successfully? If it did, it should show it in the recorder field when you reopen the Clipping preferences. If it shows "Click to record shortcut" then it didn't successfully record and set that shortcut. When I try using control-option-space as the clipping shortcut, it won't successfully record. It works fine as the quick entry shortcut, though. I have found some references to control-option-space being defined as "switch to next input source" something to do with multiple language keyboard support, perhaps? Doesn't really make it clear to me why it works for quick entry and not clipping...

If the only problem you have with using cmd-< is that it doesn't work in Pages, don't forget that you could just invoke the clipping service through the Services sub-menu under the Pages menu. If the bulk of your clipping is done in other applications, that might not be unacceptable (it's what I would do, because I like cmd-< and the only time I've clipped something from Pages is while trying to answer your post!)
 
Yeah, this isn't recording the clipping shortcut and I have no idea why. It always says "click to record" and doesn't have one. But in "quick entry" it does.
 
Sorry for the trouble here, Kevin - if you email or call (800.315.6664) our support ninjas we can help figure out what's going on.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't set clipping shortcut tedhogan OmniFocus 1 for Mac 8 2011-08-29 03:33 PM
Using clipping with OmniOutliner JohnJ80 OmniFocus 1 for Mac 18 2011-05-13 07:43 PM
Problem using clipping with Omnifocus 1.7.5 and Firefox 3.6 fredslz OmniFocus 1 for Mac 6 2010-03-12 10:20 AM
Strange Clipping Problem lksalkeld OmniFocus 1 for Mac 9 2010-01-26 02:29 PM
Clipping jltdm OmniFocus 1 for Mac 2 2010-01-18 06:24 PM


All times are GMT -8. The time now is 05:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.