The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniPlan > OmniPlan for iPad
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Refuses to publish Thread Tools Search this Thread Display Modes
I can't believe how buried the Sync functions are in this app.

Ok, now that *that* particular frustration has been vented, OP for iPad refuses to allow me to sync, because "This plan can not be published while". And then it ends. This is the red text I see when I hit "Publish". If I hit "Update", it says something similar about, but it goes on to explain that there are conflicts (it won't bring it up now so I can't quote it verbatim).

It says this even if I turn off Change Tracking. Because I don't care.

The View tab, under Change Tracking, says "1 change, -1 changes". Setting aside what "-1 changes" might mean, when I tap it, it lists no changes (I accepted them all a minute ago).

This is extremely frustrating. It's all so transparent in OmniFocus.
Ok. I tried to delete the OP file from the OmniSync Server via OP/Mac. It then magically showed up on my iPad (I had renamed the iPad version, so now there are 2 on it, which is fine). But when I tried to delete the should-be-gone version that just magically got synched to my iPad, it brought up a "Document Deleted in Another Location" dialog with "Delete" and "Keep" buttons, neither of which worked.
and it's a modal dialog. Awesome.

This is not feeling ready for prime-time.
I've managed to get myself into a situation where my plan won't publish (I have updated) because of conflicts, but it doesn't display any conflicts so I can't resolve them :-(
I'd try force-quitting the app and restarting it. I've seen some weirdness with OP for Mac where it decides something nutty, but it doesn't persist over a restart of the app. If there's a real conflict, it should calculate it again and show you. If not, you should be clear to publish.
I tried all the obvious stuff - restarting, deleting and re-downloading the plan, none of which helped. I think it had corrupted the remote DB at that point (though not irreversibly).

At one point I managed to get it into a state where it thought I had a negative number of changes/conflicts - but didn't list any, so I couldn't resolve them!

The only thing that cleared it was doing an update and sync from the desktop which presumably "fixed" the repository and then re-downloaded the plan to the iPad.

It's been fine since then.

But I'm keeping backups :-)
Hmm, my expectation is that had you truly mangled the remote copy, the desktop would not be able to publish, either.

If it does happen again, grabbing a copy of the repository copy and of the iPad copy would be a good step. You can grab the iPad copy via iTunes even if the app can't publish it.

I only recall losing data once during the beta, thanks to a bug where the document picker would open the document in the background, get confused, and save, causing my unsaved changes to be lost. That bug appears to be fixed.
Ran into this myself just a few minutes ago. 13 conflicts/-12 changes. Deleted the project from my iPad and downloaded a new copy from the server. Turned off change tracking on both laptop & iPad and everything seems to be OK now. Good thing I'm the only one editing the schedule.

Hopefully this sync issue is isolated to change tracking problems. -12 changes doesn't make a lot of sense.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
OmniGraffle refuses to start xsive OmniGraffle General 1 2011-01-21 12:15 PM
1.5 release candidate 2 refuses to quit andrewcheetham OmniFocus 1 for Mac 1 2008-11-13 06:33 AM
SOLVED: iPhone OmniFocus refuses to sync with WebDAV, authentication issue lazerfire OmniFocus for iPhone 0 2008-08-02 04:14 PM
96365 refuses to open! jeffg OmniFocus 1 for Mac 8 2007-12-20 06:42 PM
page refuses to load OW Safari Drayon OmniWeb Bug Reports 0 2007-10-13 08:04 PM

All times are GMT -8. The time now is 05:44 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.