The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
[SOLVED] Help! OmniFocus hangs; won't complete sync; etc. Thread Tools Search this Thread Display Modes
Quote:
Originally Posted by DragonDave View Post
LOL... Well, misery loves company, I guess. Just a shame it happened on a Friday. Probably no fix until at least Tuesday at the earliest. They should institute a "no releases on Friday in case we break something" policy...
We actually do generally have this policy for regular betas and of course final releases. Sneaky peeks are a deliberate exception. By choosing to run the Sneaky Peeks, you are opting in to completely untested builds. If you're not comfortable with that, you should be using an official release (currently 1.0.3), or maybe intentionally not downloading builds until they've been posted for a day, to see if anyone else is having disastrous problems.

If the problem you're seeing is in fact addressed by running the CoalesceDatabase script, then I suspect the bug is one that's been in our builds for some time. (And yes, we do plan to fix it.) It's the kind of bug that secretly bloats your file for a long time, until eventually it's too big for OmniFocus to load properly. So it could be just very unfortunate coincidence that things went sour this weekend.

-----

Regardless, if you're still stuck, please email urgent@omnigroup.com so we can get you unstuck when our Ninjas are back at work tomorrow morning.
 
Thanks for the reply, Lizard. I'll certainly be cognizant of the perils of new sneakypeak builds on the cusp of weekends.

Add me to the list of poor suckers who this issue has hit. Here's a brief description that I think mirrors DragonDave's issues

1. Had a sync (to my idisk) that seemed to never end. Tried to quit OF, resorted after a long while to force-quit.

2. On subsequent startups of the program, OF gets stuck before displaying anything but its dock icon, and is pegging the cpu.

3. Trying the CoalesceDatabase script starts OF - but it hangs before anything happens, similarly locking up and pegging the cpu. Applescript eventually throws up a dialogue box showing: "OmniFocus got an error: AppleEvent timed out."

Is there anything we users can do to help?
 
Delete the corrupted OmniFocus.ofocus file from ~/Library/Application Support/OmniFocus, then open OmniFocus and revert to a backup (default location for backups is ~/Documents/OmniFocus Backups). Then run the script.

This did the trick for me.
 
FYI... Running the CoalesceDatabase script DID fix this problem for me (my DB was at about 4 MB). Thanks for the feedback and help it getting the fix.

I assume we should run this periodically until problem is noted as being fixed or final release?
 
Quote:
Originally Posted by Lizard View Post
We actually do generally have this policy for regular betas and of course final releases. Sneaky peeks are a deliberate exception. By choosing to run the Sneaky Peeks, you are opting in to completely untested builds. If you're not comfortable with that, you should be using an official release (currently 1.0.3), or maybe intentionally not downloading builds until they've been posted for a day, to see if anyone else is having disastrous problems.
While that's true and I'm comfortable with that, I have to point out that there is currently no way to run OF for iPhone as it's intended to work (with syncing) without running an untested developer build of the desktop app, so advising people to use an official release isn't really a reasonable option, is it?
 
Quote:
Originally Posted by gaba View Post
Delete the corrupted OmniFocus.ofocus file from ~/Library/Application Support/OmniFocus, then open OmniFocus and revert to a backup (default location for backups is ~/Documents/OmniFocus Backups). Then run the script.

This did the trick for me.
This worked for me too, but I had to make sure that I was not connected to the internet, so syncing wouldn't start and inevitably hang. So here's what I did in detail:

1. Deleted OmniFocus.ofocus file from ~/Library/Application Support/OmniFocus.

2. Before starting up OmniFocus, I disconnected from the 'net (to stymie an automatic sync that would seem to hang every time)

3. Started up OmniFocus and reverted to a backup

4. Ran the CoalesceDatabase script.

5. Quit Omnifocus and reconnected to webernets.

6. Mounted idisk and deleted OmniFocus.ofocus from that location

7. Started up Omnifocus - sync worked like a charm.

8. Started the iPhone version of OmniFocus. Upon syncing, it replaced its database with the new one.

I don't know if all steps are absolutely necessary, or even contribute to solving the same problem, but they did indeed fix the problem of syncing that began to take longer and longer, and eventually wouldn't work at all.

Yay, I've got my external brain back! Time for me to G some TD!
 
This hang should be fixed in the latest builds (104538 or later).
 
Quote:
Originally Posted by al_f View Post
While that's true and I'm comfortable with that, I have to point out that there is currently no way to run OF for iPhone as it's intended to work (with syncing) without running an untested developer build of the desktop app, so advising people to use an official release isn't really a reasonable option, is it?
Syncing OmniFocus for iPhone with your iDisk all by itself - backing up your data via WebDAV - is totally supported, requires no beta software, and is a much simpler process to write, test, and support. :-)

It's true that a lot of folks are interested in syncing the iPhone with OmniFocus on the Mac, but there are other ways to use the iPhone app. Folks on Windows, for example, use the app this way.

While I'm on a soapbox, if anyone out there is doing this and isn't syncing their data, we strongly recommend that they do. If the iPhone ever nukes your data and you don't have a recent backup of your phone, you're kinda hosed.
 
Quote:
Originally Posted by Brian View Post
Syncing OmniFocus for iPhone with your iDisk all by itself - backing up your data via WebDAV - is totally supported, requires no beta software, and is a much simpler process to write, test, and support. :-)
Fair point. :)

Don't get me wrong, I think you're doing a great job with OF overall. Keep up the good work!
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
OmniFocus hangs during sync after updating to 1.9? carloszz8 OmniFocus 1 for Mac 4 2011-04-20 03:38 PM
Unable to sync w/Bonjour since iPhone Omnifocus update [SOLVED: Blocked by router.] Nutty87th OmniFocus Syncing 7 2010-04-29 01:44 AM
Can't get OmniFocus to sync with iPhone [SOLVED] jim0203 Bonjour sync 17 2010-04-28 11:07 AM
Sync Stopped Working Using Bonjour [SOLVED: Firewall on Mac blocking sync] ajgilbert Bonjour sync 4 2009-06-21 09:46 AM
SOLVED: iPhone OmniFocus refuses to sync with WebDAV, authentication issue lazerfire OmniFocus for iPhone 0 2008-08-02 04:14 PM


All times are GMT -8. The time now is 01:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.