The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Atom feeds not recognized as feeds? Thread Tools Search this Thread Display Modes
I have been using Omniweb for a few weeks and really love the way it flows, but have found a few niggly issues.

I use Stikkit for keeping little notes and Todos for my projects, and it works great in OW. It is also a hometown company for me here in Portland, OR. Stikkit has a nice atom feed that allows you to see all your notes organized by tags. This feed works great in FF, but does not work at all in OW.

The URL of the feeds do not end in an XML extension like typical RSS; the link Stikkit provides to subscribe to a feed is formed like this:

http://www.stikkit.com/tags/<your tag name here>.atom?api_key=d1184696e3de621b7c46575ae9eac80 7

The tag name is of course represented without the brackets, and I have changed the API key for this example.

This URL results in a goofy text display in OW, while in FF it prompts me to add the item as a Live Bookmark (or use some other feed reader). I have tried several workarounds, but nothing seems to make OW recognize this as a feed.

It works in Safari, BTW - so it doesn't appear to be a generic WebKit issue.

Wazzup with that? Any ideas about this in the OW community?
 
I get the same thing. The way around that is to just copy the url and stick it where you want it.

And yeah, it's only Atom feeds that this seems to mess up on. If they add the "feed://" url instead of "http://" it seems to work fine. That's how I got around it on my site, but that would only send it to my RSS feedreader (NetNewsWire).

Until today, I didn't know that OmniWeb had a problem handling Atom feeds just as bookmarks.
 
Thanks for the tip, MacStansbury. While that trick seems to make the bookmark manager think it is a feed (the icon changes to a "newspaper") it still does not work with Stikkit - the same raw text output appears when link is clicked. It other words, OW doesn't see it as a feed, just a page of text.

I will have to find some other atom (not RSS) feeds to play with and see what, if any differences there are.
 
I just tried several atom and rss feeds from google - same result. If I choose an RSS feed, OW prompts me to subscribe to it (correct behavior). If I choose an atom feed, I just get a page of raw text, no subscription.

It just seems broken, that's all. Atom doesn't appear to work at all with OW 5.5.
 
Atom feeds don't work in OmniWeb (and never have). Feel free to send votes in using the Send Feedback link in the Help menu. This is something we'd like to support in the future.

Thanks!
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
rss feeds Harvey Leff OmniWeb General 5 2009-04-10 12:36 PM
Custom CSS for RSS feeds marc OmniWeb Feature Requests 2 2009-03-30 11:51 AM
5.7 and RSS Feeds theonehorst OmniWeb Bug Reports 7 2008-01-18 07:34 AM
Looking at rss feeds sickbar OmniWeb General 6 2006-11-06 10:07 AM
RSS feeds in 5.5sp4? MinutiaeMan OmniWeb Bug Reports 6 2006-05-18 10:20 AM


All times are GMT -8. The time now is 06:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.