The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Hierarchical tasks don't appear in Due? [A: Enable "show groups in context mode"] Thread Tools Search this Thread Display Modes
Hi all,

I have a project that contains a couple of hierarchical tasks:

- task 1
- sub-task 1.1
- sub-task 1.2
- task 2
- sub-task 2.1
- sub-task 2.2
- sub-task 2.3

Both task 1 and task 2 are Due today.

I have a perspective defined as:

- Context view
- Context filter: All contexts
- Grouping: Due
- Sorting: Flagged
- Availability filter: Remaining
- Status filter: Due or Flagged
- Estimated Time Filter: Any Duration

When I switch to this perspective all sub-tasks are displayed. SUPER!
After completing the sub-tasks, I switch back to this perspective to see what's next, expecting to see the 2 parent tasks in there. But they are not! Whatever I do, I cannot get OmniFocus to show those in the list.

I thought that it might be something wrong with my perspective, so I've tried the default Due perspective. And guess what? Even if both task 1 and task 2 are due today and there's a badge for them in the project perspective, they do *not* show up in the Due perspective. Basically that means it would be very easy to just miss those!

What am I missing? Is there something I don't understand or is this a bug?

thanks in advance,

A://
 
If you create sub-tasks under a parent task, the parent becomes an Action Group in OmniFocus. By default Action Groups do not appear in context mode lists, but you can change this behavior. Go to preferences>data>projects & action groups and check the option In Context Mode: Show Projects and Action Groups.
 
Another possibility is that you do not have a context assigned to the action groups, and you did not have the No Context bin selected when you made the perspective. The default for showing projects and action groups in context mode is actually on, not off, and by default, the No Context bin isn't part of the selection when you switch to context mode.
 
Quote:
Originally Posted by Greg Jones View Post
If you create sub-tasks under a parent task, the parent becomes an Action Group in OmniFocus. By default Action Groups do not appear in context mode lists, but you can change this behavior. Go to preferences>data>projects & action groups and check the option In Context Mode: Show Projects and Action Groups.
This did it. Thanks
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to show an item in one mode in the other mode? [A: View menu or "Switch" button] ckennedy OmniFocus 1 for Mac 4 2010-06-27 04:23 AM
1.6.2 "...Projects can now appear in Context mode perspectives" oh no! cfrre OmniFocus for iPhone 6 2010-04-22 03:51 AM
canīt assign a project to an action in "context mode" levy OmniFocus 1 for Mac 5 2008-01-07 12:59 PM
Missing "Show in xxx Mode" shortcut? jasong OmniFocus 1 for Mac 11 2007-12-16 08:04 PM
"Show in [Project/Context] View" Command dhm2006 OmniFocus 1 for Mac 5 2007-08-10 05:29 AM


All times are GMT -8. The time now is 08:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.