The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Flat file sync error Thread Tools Search this Thread Display Modes
I just updated to the latest build of OmniFocus. I now get the Error "expected a directory at ********** but got a flat file". I get the same message when trying to sync my iPod touch.

I'm syncing to a web dev that I set up locally on my MacBook Pro.

Any help is greatly appreciated.

Thanks.
 
I'm sorry for the trouble this is causing - we'll probably need more information to figure out what's going on here, and I'm not sure that info is going to be particularly forum-friendly.

Can I ask you to try the following, and email the results to omnifocus@omnigroup.com so the support ninjas can help?

Open Terminal.app (in your Utilities folder). Quit OmniFocus, if it is running.

Paste this command into the window:
Code:
defaults write com.omnigroup.OmniFocus XMLFileManagerDebug -bool true
Next, open Console.app (in the same folder as Terminal.app), start OmniFocus, and try a sync.

We'll get a lot more debug information written to the console window. Can you send it to us?

You can then disable the sync logging by entering this command:
Code:
defaults write com.omnigroup.OmniFocus XMLFileManagerDebug -bool false
Thanks!
 
Done. Note that I now get a message that says "can't find host". Hopefully we can get a resolution soon as I live by OmniFocus syncing with my iPod Touch. Thanks for your help.

Last edited by Smhearty; 2009-02-11 at 05:59 PM..
 
I switched over the sync to Bonjour. That solves it for me. Still don't know why the Webdav doesn't work.
 
Who is your WebDAV server host? E.g. some people were experiencing an issue with DropBox, iirc, recently which had to be resolved on the server end (they had updated their settings and made a mistake in the process).
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
File open error Monteverdi OmniGraffle General 1 2010-10-29 10:30 AM
WebDAV - expected directory but got flat file? Hoff Other WebDAV 6 2010-04-19 07:34 PM
Saving as flat file for default John Lallemand OmniGraffle General 2 2009-12-29 10:46 AM
Can open a graffle file, getting error fchan OmniGraffle General 1 2009-01-29 07:52 AM
Flat file? looze OmniGraffle General 5 2008-10-10 06:31 AM


All times are GMT -8. The time now is 12:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.