The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Mail Rule vs Clip-O-Tron Thread Tools Search this Thread Display Modes
I've been using the mail rule with the +omnifocus address for a while and am now starting to play with the Clip-O-Tron 3000 (gotta love the name). So far I really like the way the Clip-O-Tron works in that the new task has not only the subject, but the fully formatted content of the message (except attachments) and a link back to the message in mail.app.

The mail rule works fine if I'm just sending a message specifically tailored as a task, but it rarely gets things correct for me when I forward received messages from my Outlook/Exchange email at work to OmniFocus. The forwarded messages frequently contain "--" somewhere in the body, which gets interpreted as the end of the task note or a new task depending on something I haven't yet figured out. So all-in-all I like the results Clip-O-Tron better.

Unfortunately the Clip-O-Tron requires a manual intervention step using either the shortcut key or menu selection. Is there a way to put that in a mail rule to have it automatically processed? I'm not seeing any way to use a service as part of a rule unless there is some way to do it via applescript (I can open the editor but have no clue as to how to actually create a script).

Barring that, is there a way to get the new action created by the mail rule to include the "original message" link? That would be a big improvement for me. Or is the thought here that the rule is exclusively used for things you know you want to be actions, but the Clip-O-Tron is meant to work with any old thing.

Regarding the messages that contain "--" in the body... On a hunch I made a copy of MailAction.applescript and looked at it in the script editor. I looked for "--" to try and change the delimiter but I was unable to locate it in an area that looked like it might be the correct spot. Changing it in the OmniFocus Mail Preferences just seems to change it for what messages get grabbed by the rule, so I'm guessing that it's hard coded somewhere else. Is that part customizable anywhere?
 
Quote:
Originally Posted by shovland42 View Post
Regarding the messages that contain "--" in the body... On a hunch I made a copy of MailAction.applescript and looked at it in the script editor. I looked for "--" to try and change the delimiter but I was unable to locate it in an area that looked like it might be the correct spot. Changing it in the OmniFocus Mail Preferences just seems to change it for what messages get grabbed by the rule, so I'm guessing that it's hard coded somewhere else. Is that part customizable anywhere?
In the script, you can always pre-process the text of the message before it gets sent to the OF black box routine. I've done this to make : a comment character that gets stripped out before being sent to OF, and then I use that as a line prefix in my iPhone sig...

-P
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Clip-o-Tron with Mail.app on Lion alex.vollmer OmniFocus 1 for Mac 4 2013-01-14 08:53 PM
Clip-o-Tron from Mail rule? grichar1 OmniFocus Extras 8 2011-06-20 09:48 AM
Mail Clip-O-Tron 3000 kanders001 OmniFocus 1 for Mac 1 2009-11-12 01:42 PM
Help - Clip-o-tron and Mail 4.1: not working for me. Tinchohs OmniFocus Extras 3 2009-09-24 01:05 PM
Mail Clip-O-Tron 3000 has me baffled? jwhitetoo OmniFocus 1 for Mac 5 2008-01-14 09:35 AM


All times are GMT -8. The time now is 01:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.