The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Webloc's dragged from OW do not open when double-clicked Thread Tools Search this Thread Display Modes
If I drag a URL from the Address Field in the front-most OW 5.5 window to my desktop, it creates a .webloc file that indicates it will open in OmniWeb. However, double-clicking this file instead opens:

1. A blank window in OW, and...
2. A Finder window showing the file.

If I drag-and-drop the .webloc onto an OW window, the page to which the file points opens.

This is not how it worked prior to 5.5. In 5.1.3, double-clicking such a .webloc opened the page in OW.

I noticed the following:

1. If I drag a URL from Safari's Address Field and create a .webloc in the same manner, it won't open in OW either, even though OW is the default app for such. If I change that .webloc's default app to Safari, double-click it, it opens in Safari.

2. If I take the .webloc created in Safari and drop it on TextEdit, it appears as an empty file. In HexEdit, I can see, however, there are contents, e.g. the URL to which the .webloc points.

3. If I take a .webloc created by dragging an address from the Address Field in OW to the desktop, then open that .webloc in TextEdit, it reveals the contents are an XML property list in plain text. For example:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>URL</key>
<string>http://radar.weather.gov/ridge/radar.php?rid=FWS&amp;product=N0Z&amp;overlay=1110 1111&amp;loop=yes</string>
</dict>
</plist>

I'm running:
Product: OmniWeb-5.5
Tag: OmniWeb-5.5-v607
Date: 2006-08-30 14:24:56 -0700

On:
Power Mac G5 Dual 2.3 GHz w/ 4.5 GB RAM, Mac OS X 10.4.7

Last edited by Dr. Smoke; 2006-09-12 at 03:30 AM..
 
Quote:
Originally Posted by Dr. Smoke
If I drag a URL from the Address Field in the front-most OW 5.5 window to my desktop, it creates a .webloc file that indicates it will open in OmniWeb. However, double-clicking this file instead opens:

1. A blank window in OW, and...
2. A Finder window showing the file.
I'm not getting this problem. My .webloc files open in OmniWeb even though the Finder is supposedly the default handler.
 
Quote:
My .webloc files open in OmniWeb even though the Finder is supposedly the default handler.
By "default handler" do you mean the application listed in the pop-up menu in the Open With pane of the Get Info window for a .webloc?

In my case, the default application is OW 5.5, not Finder, as it should be.
 
Quote:
Originally Posted by Dr. Smoke
By "default handler" do you mean the application listed in the pop-up menu in the Open With pane of the Get Info window for a .webloc?
Yes. If I change the default to OmniWeb, then I get the same behaviour as you.

Not a problem with OmniWeb then?
 
No, I would say it is a problem with OW. If the default app is OW, it should open in OW. Either that, or some difference between how the drag-and-drop from the Address Field in OW to the desktop is handled with OW vs. Safari.

The fact that the .webloc created by dragging from OW appears as a plain-text XML property list vs. the "empty" file created by doing the same in Safari may give the OW developers a clue.

What's interesting is I can reproduce what you reported: If I open the .webloc with Finder, it opens a new browser window in OW and displays the page. That's not how it should work.
 
Ah, I see what you mean. Sorry, I'm a bit slow.
 
No problem. I appreciate your responses to my topic and hope the developers will take a look at this issue.
 
It does look like there are some issues with local files at the moment. We have a bug open on this and will be looking into it. Sorry for the trouble here.
 
While this was supposedly fixed in, if memory serves, 5.5.2 b2, there are still problems with Weblocs in OW 5.5.2 b3:

1. "Old" Weblocs, i.e. Weblocs created prior to OW 5.5, still do not open in OW if double-clicked. If I create a new Webloc by the method discussed in my first post above using OW 5.5.2 b3, it opens in OW 5.5.2 b3 as expected. However, Weblocs that I had created prior to OW 5.5. do not open in OW. These still open in the latest version of Safari.

2. Weblocs created in the latest version of Safari (by the same dragging method) do not open in OW if double-clicked, despite OW being the default browser and the Open With app being OW 5.5.2 b3 for these Weblocs.

3. The format of Weblocs created by OW 5.5.2 b3 and Safari are completely different. This seems to be the root cause of the problem:

- Weblocs created by OW open in TextEdit and show an XML structure.

- Weblocs created by Safari are blank in TextEdit, but reveal their contents in HexEdit.

- Weblocs created by Safari and OW show completely different internal formats when examined in HexEdit.

- "Old" Weblocs created from OW prior to 5.5 show the same internal format as current Safari Weblocs.

For some reason, OW developers changed the format of Weblocs created from OW — by the methods I originally outlined — from the same format used by Safari to some OW-specific format. The new OW format opens in Safari, either by dragging and dropping them on a Safari window, or using Open With... However, Weblocs in the Safari format — which was also the format from OW prior to 5.5 — do not open in OW if double-clicked.

It would seem to me that the format of Weblocs should be consistent across browsers, hence OW 5.5.2 b3+ could open Weblocs created in Safari and vice-versa.

Last edited by Dr. Smoke; 2006-12-17 at 02:22 PM..
 
I'm having this problem with .url files too.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Double-click for Focus in New Window gone? [A: v1.9 changed to Option-Double Click.] bjornkri OmniFocus 1 for Mac 11 2012-05-17 09:52 AM
Disable "double click on a tab preview to open in a new window" dangerous OmniWeb Feature Requests 2 2007-08-22 04:33 PM
Titles of dragged links? JDub OmniOutliner 3 for Mac 1 2007-02-15 01:19 PM
Bookmarks are copied, not moved, when dragged ebob OmniWeb Bug Reports 5 2006-12-17 06:51 PM
Open a new tab by double-clicking an empty space in tab drawer musti OmniWeb Feature Requests 1 2006-07-11 07:20 PM


All times are GMT -8. The time now is 02:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.