The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Line ending bug in layers Thread Tools Search this Thread Display Modes
I apologize if this has been reported before, but I couldn't find mention of it.

I am trying to produce a wiring diagram. The wires are color coded with a base color and a stripe. Since there appears to be no way to control the internal color of a double stroked line, I opted to put the base color on one layer then layout an identical line over it with the strip color. I use 6pt ortho line on the base layer, and 2 point ortho line on the strip layer. Aside from the extra effort, it work fine except at the line ends.

When I put a stripe line over the base line the base line is not drawn all the way to the component.


If I shift the end point of the stripe line over one magnet, then the base line is drawn correctly.


I have attached PNGs of the problem, as well as a demo graffle file.

Is there a work around?

I have found one work around: draw the line in the opposite direction. The strip line is drawn in the opposite sense form the base line, then the gap doesn't appear.
Attached Thumbnails
Click image for larger version

Name:	bug1.png
Views:	215
Size:	57.9 KB
ID:	2054   Click image for larger version

Name:	bug2.png
Views:	195
Size:	57.8 KB
ID:	2055  
Attached Files
File Type: zip Bugdemo.graffle.zip (5.0 KB, 134 views)

Last edited by enderw88; 2011-10-16 at 02:44 PM..
 
Looks like a pretty bad bug. It gets even worse if you put an arrowhead on upper end of the black line. I'd report it as one to OG; use the Send Feedback item in the Help menu.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Round line ends not centered on end of line billbrietstout OmniGraffle General 3 2012-05-17 08:08 AM
shared layers kajtzu OmniGraffle General 2 2009-09-24 08:45 AM
Converting Standard Layers to Shared Layers PRV OmniGraffle General 3 2009-07-07 09:48 AM


All times are GMT -8. The time now is 09:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.