The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Selected Object Exports at Different Size Thread Tools Search this Thread Display Modes
I am trying to understand why shapes without strokes are exporting at slightly different sizes.

If I create a rectangle, for example, which is:
1. 125 pixels wide and 26 pixels tall
2. No stroke
3. Fill: Solid Color

and export it as a PNG
1. Format: PNG bitmap image
2. Export Area: Current Selection
3. Include non-printing layers = off
4. Include margin = off
5. Scale = 100%
6. Bitmap Resolution = 72 dots per inch
7. Transparent Background = ON

The resulting image is 126 pixels wide and 26 pixels tall.

Any idea why this image is exporting one pixel wider than the selected object? I know this sounds like a very small issue (literally a pixel), but it's just one of those situations where I need to submit objects of specific sizes, and before I change workflow to exclude Omnigraffle Pro, which I love, I wanted to do a reality check with you all to see if I was missing something straightforward.

Thanks, - K.
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2013-05-24 at 5.19.14 PM.png
Views:	443
Size:	29.3 KB
ID:	2847   Click image for larger version

Name:	Screen Shot 2013-05-24 at 5.20.11 PM.png
Views:	407
Size:	7.4 KB
ID:	2848  
Hmmm. I know this won't help, but I tried to duplicate this with a 125x26 rectangle with no stroke, all export settings like yours, and my output PNG (as reported by Finder) was 125x26. If I imported the PNG to OmniGraffle, the Geometry Inspector still reports 125x26.

Maybe you have a shadow set? I don't know what else it could be. Does Finder report the same (wrong) size?


As a side note, I tried the same thing with a 1pt stroke on the rectangle, and my exported size was 129x30. Odd, since I'd expect at most a 2pt increase per dimension.

So I opened it in Fireworks and found the raster rectangle was 126x27 (apparently the stroke is centered on the border), and for some reason it was sitting within a transparent background of 129x30.

This seems like a bug, as the rectangle should fill the transparent background. The same thing happened if I specified a margin of 0 on export. Also, it didn't matter what format I exported to - even PDF showed the rectangle sitting within a larger background in Acrobat. Seems like the only anti-aliasing would be on the rounded corners, and that shouldn't extend beyond the rectangle bounds. Even if the corners are square I get this extra space.


Have you tried opening the image in a raster graphics program (Photoshop, Fireworks) to see if you have 1px of transparency on one side of the rectangle or the other? Not that this would solve your problem, but at least you'd know what was going on.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

All times are GMT -8. The time now is 09:58 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.