The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Restoring settings after uninstall Thread Tools Search this Thread Display Modes
So after some moving around of my home directory (switching computer setups, HDD to SSD/HDD etc) my omnifocus became unusable. Gave the error unable to write lock file, and deleting the lock file in both application support and library pref. didn't work either, so I was forced to uninstall the app - which cleared out all the data including in ~/library.

I didn't realize the backups omni keeps is only the information in the database, not the setting, which is kinda useless if your syncing, I could have just pulled the data off the synced network copy....anyhoo, is there a way to restore settings (such as saved perspectives, scripts, and colors/fonts/etc)?

If not, where are these setting saved? Before I deleted all the plists and com. files, I copied everything into a folder just in case, so I could replace the newly created files if necessary to go back. Worst case I have a time machine backup, but since i've made a lot of changes in my system since this morning, I would rather NOT use this option. Any help would be greatly appreciated!
 
Perspectives are saved in the database itself. Settings from the preferences panels are mostly saved in the com.omnigroup.OmniFocus.plist file in ~/Library/Preferences, but some are in the database, which goes in ~/Library/Application Support/OmniFocus.

It's a little late now, but when you encountered trouble, you should have called up Omni support rather than blindly charging off the cliff.
 
It was not so much of an Omni-problem, as nuking the lockfile.plist wouldn't allow the program to open (as the ninjas would have recommended). I knew it was going to be a permissions and ACL problem from the user move, and since I copied the application support and plists in preferences, I knew I could always go back.

Was able to run the "secret" permissions and ACL repair tool (password reset in terminal after booting off the recovery partition) after copying the plists and support files back into the library, and everything is honky dory now and back. I know enough to get me in trouble, and know enough to make copies of things and backups before making changes in case my limited knowledge backfires ;)
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Uninstall Xevious OmniFocus 2 for Mac (Private Test) 4 2013-05-06 08:53 AM
How to do a clean uninstall... frankmcma OmniFocus 1 for Mac 1 2009-07-28 07:23 PM
Clean uninstall?... frankmcma OmniFocus 1 for Mac 3 2009-02-12 02:05 PM
Feature Request: Move Settings to Settings application Grail OmniFocus for iPhone 3 2008-09-19 04:38 PM
How to uninstall RFBriggs OmniFocus 1 for Mac 5 2007-10-19 05:58 PM


All times are GMT -8. The time now is 11:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.