The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniOutliner > OmniOutliner 3 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Rows not sorting Thread Tools Search this Thread Display Modes
Hi-
I'm trying to sort my 1st level rows in alpha order. Usually, I have no problem, I just click Reorganize>Keep Sorted. But for some reason, it's not doing it. Can anyone suggest what I might be doing wrong? Thanks much.
 
I'm sorry for the inconvenience this is causing - I created a test document on my machine (OmniOutliner Pro v3.7.2 running on 10.5) and was able to sort the rows by selecting
Reorganize -> Keep Sorted -> Topic (A to Z)

That sounds pretty much like what you're describing, but maybe there's something specific to the document you're trying to sort that's tickling a bug or something. If you send the document as an attachment to the support ninjas - you can use "Send Feedback" under the help menu - we'll take a look and see if we can determine what's going on.
 
Quote:
Originally Posted by SurfKauai43 View Post
Hi-
I'm trying to sort my 1st level rows in alpha order. Usually, I have no problem, I just click Reorganize>Keep Sorted. But for some reason, it's not doing it. Can anyone suggest what I might be doing wrong? Thanks much.
One possibility -- are you still editing one of the rows? It won't resort while one of the rows is open for editing, in my experience. Click in the margin and try again.
 
SurfKauai43, did you ever resolve this problem? I just stumbled upon this thread and thought I'd suggest checking the "Sort children" setting in the "Row: Advanced" inspector for the parent row (or Whole Document if you want). Missing that checkbox has fooled me on more than one occasion. ;-)

-Dennis
 
I cannot sort either. I have never seen the choice of being able to sort by Topic. My menu shows sort by Note, not by Topic, and I have no notes.
 
You should see the options to sort by status and notes. You will also see the option to sort based on the name of any other columns you have. By default you have a Topic column but that can be renamed and that new name will be what shows in the sort menu.
 
Quote:
Originally Posted by DerekM View Post
You should see the options to sort by status and notes. You will also see the option to sort based on the name of any other columns you have. By default you have a Topic column but that can be renamed and that new name will be what shows in the sort menu.
I got a brief respite by exporting the entire file (about 0.5 mb) to an opml file, then opening that up in OO3. After doing that, I got a the option to sort on "text" as well as notes. I have no idea why the "text" option would not appear before this rudimentary cleanup.
 
If you still have the problematic file, we'd like to take a look at if if possible. You can send a copy to omnioutliner@omnigroup.com Thanks!
 
I saved the opml file over the previous oo3 file. If I run into the issue again, I'll send it to you. The sort menu looks pretty much the same now that the problem has been resolved with the exception of the option to sort text as well as notes.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Non-printing Rows BonafideBM OmniOutliner 3 for Mac 0 2012-11-07 08:22 PM
Expand all rows? Littledragon OmniOutliner for iPad 2 2011-06-18 12:47 PM
Clipping: Too many rows Andreas67 OmniOutliner 3 for Mac 1 2010-10-03 07:50 PM
Feature requests - merge rows and icons for rows maish OmniOutliner 3 for Mac 0 2008-09-19 07:12 AM
Linking Rows mjinil OmniOutliner 3 for Mac 2 2006-08-09 06:42 PM


All times are GMT -8. The time now is 01:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.