The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Can't assign clipping shortcut Thread Tools Search this Thread Display Modes
Quote:
Originally Posted by itmiller View Post
I too was having weird issues with assigning a clipping shortcut.

I recently upgraded to snow leopard (Mac OS X 10.6.2) and I noticed Clipping from other applications into OmniFocus stopped working. I went into the OmniFoucs preferences to try to record a Clippings Keyboard Shortcut but it didn't want to take/record it.

I looked in System Preferences -> Keyboard -> Keyboard Shortcuts -> Services and saw OmniFocus:Send to Inbox was checked but no keyboard shortcut was listed. I also saw OmniOutliner: Add to clippings was checked and it listed a keyboard shortcut and that worked fine for OmniOutliner. But I couldn't clip anything for OmniFocus.

It appears there's an issue with recording and storing the keyboard shortcut for clipping.

I screwed around with it for quite a while and finally managed to get a clipping shortcut recorded and everything went back to normal. Honestly I'm not really sure what steps it took to get the clipping shortcut recorded but here's my best guess at how to get it to record:

1) Go into System Preferences -> Keyboard -> goto Keyboard Shortcuts -> look at the Services and find OmniFocus:Send to Inbox. If there is no keyboard shortcut listed then you need to get one in there.

2) Now go into your OmniFoucs preferences -> clippings, and try to record a keyboard shortcut. OmniFocus will complain about System Preferences being open and ask you to quit. Go ahead and quit and hopefully your keyboard shortcut will actually be recorded this time.

The steps above worked for me. Hope this helps someone.


NOTE - maybe having System Preferences open had nothing to do with it ... it might have been me trying different keyboard combinations until one took ... I noticed that the keyboard shortcut won't record if OmniFocus doesn't like the combination you want ... so maybe it all comes down to the combination you are trying to put in ... the one that worked for me is Command Shift , (cmd-shift-comma).
I unchecked "Omnifocus: send to inbox" and after that I could assign a shortcut from within Omnifocus.
 
I am also having issues here. The quick entry window wouldn't let me assign CMD-Space (said it was in use) on my iMac, even though I have that assigned on a Macbook Pro with the exact same applications preferences (I know this because I used migration assistant to set up my iMac three days ago). I actually fixed that by editing my plist file, so that works now.

I tried using CMD-OPT-Space for clipping, and again, it works on the Macbook Pro, but will not let me assign it on the iMac. I tried to change it manually in the services preferences, and it will let me set it there (which coincidentally changes the Omnifocus prefs to show CMD-OPT-E, which doesn't work either), but it still won't work. If I use the mouse, the services menu works just fine, but the keyboard shortcut doesn't do anything. Also, the services menu doesn't show a space in the keyboard shortcut area, it just has the symbols for command and option.

Is there an inherent problem with using space in the shortcut? If so, why does it work on my Macbook Pro? Is there a plist file I can just edit somewhere to bypass that god-awful shortcut recorder widget?
 
If I remember correctly, the default shortcut for showing the Spotlight menu is command-space, and the Spotlight results window defaults to command-option-space.

You may want to check and see if those services or shortcuts are active in System Prefs. I think there are a few settings that Migration Assistant doesn't bring over to a new machine. I'm not sure, but this may be one of them...
 
Clarification: OmniFocus' preferences got brought over to the new Mac. It's possible that the System Preferences related to those Spotlight shortcuts weren't brought over.

Realized I didn't write that last post at all clearly...

Last edited by Brian; 2010-03-08 at 03:20 PM.. Reason: "related whether to" --> "related to". BRIAN NEED COFFEE.
 
Good thought, but I have tried reconfiguring that in several ways as well. I have tried changing spotlight and spotlight window to opt-space and ctrl-opt-space, respectively. I have disabled them. I have done both of those together (trying once in one order and again in the other). I have gone through the sticky thread about clipping, and tried disabling every system shortcut, then tried it, and it still doesn't work. Thanks so much for the help, any other ideas?
 
Hmmm... I'm able to reproduce your symptoms - the keyboard shortcut isn't settable in OmniFocus. If you set it to that shortcut in System Preferences, OmniFocus' preferences show Command-Option-E - but that shortcut doesn't actually work.

I'm going to go ahead and write this up as a bug so the dev team can have a look at the problem, but for the time being you're probably going to need to pick a different shortcut. Thanks for letting us know about the problem, and I'm really sorry for the trouble this is causing.
 
I have three macs (two imacs and a brand new MBP) and I've been using CMD-CTRL-OPTION-DownArrow for my shortcut for mail-to-OF.

Right now, I don't think that i can assign ANY shortcut to OF on the newly installed MBP. When I hit the modifier keys, they show up in the little "Click Here to Record" but no matter what I do, nothing will actually record. Not space, not a letter, nothing.

I'll submit this as a bug via the feedback...

-Scott
 
Quote:
Originally Posted by qtus View Post
I unchecked "Omnifocus: send to inbox" and after that I could assign a shortcut from within Omnifocus.
I had the same issue with assigning the clipping shortcut. Unchecking "Omnifocus: send to inbox" in System Preferences -> Keyboard -> Services and then trying again in the OmniFocus clipping preferences worked fine for me. Thanks qtus!

I use Ctrl+Option+Command+Space shortcut for clippings.
 
Thanks itmiller. That helped! Your solution didn't give me a result but helped me solve it.

My steps:

I looked in System Preferences -> Keyboard -> Keyboard Shortcuts -> Services and saw OmniFocus:Send to Inbox was checked but no keyboard shortcut was listed.

I then went to OmniFocus preferences -> clippings, and entered a keyboard shortcut ending in C. OmniFocus dialogue box appeared complaining about System Preferences being open. I clicked Cancel option. My shortcut remained recorded in Clipping settings.

I checked System Preferences -> Keyboard -> Keyboard Shortcuts -> Services and saw OmniFocus:Send to Inbox had the appropriate shortcut.

I opened Textedit to test. Wrote some copy, highlighted some of it and did the keyboard shortcut: it didn't work!

So, I closed Omnifocus, then launched it again. closed Textedit and relaunched. Tried it again: it worked!

Now, I'm not totally convinced that the sequence above provided the solution. I suspect there's a bug and it's just a matter of trying again and again until something just gives.

Info for the Omnifocus people:

Mac OS X version 10.6.4
Omnifocus 1.7.5 (v77.41.6 r121031) in trial mode.

This has taken up 90 minutes :(

Not so productive....
 
I was able to get a shortcut to "take," and use it to clip some text from TextMate.

However, the same shortcut did not work for clipping a link to the selected file in Finder. I am sure things used to work this way. (I've been settling for the lack of a shortcut since a clean re-install a few months ago.)
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
assign resource shortcut? clayc OmniPlan General 0 2012-04-03 06:24 PM
Cannot assign shortcut to clipping services after upgrading to Snow Leopard tosz OmniFocus 1 for Mac 9 2011-04-05 06:43 AM
Can't Assign Keyboard Shortcut mtennes OmniFocus 1 for Mac 1 2008-06-19 08:56 PM
How to assign a shortcut to an Apple Script? Tinchohs OmniFocus Extras 2 2007-12-16 07:18 PM
Re-assign a keyboard shortcut? Tinchohs OmniFocus 1 for Mac 2 2007-12-12 03:10 PM


All times are GMT -8. The time now is 05:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.