The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Can't assign clipping shortcut Thread Tools Search this Thread Display Modes
Just guessing, but once the shortcut is assigned you may need to restart Finder by logging out and back in.
__________________
Cheers,

Curt
 
[QUOTE=itmiller;73462


NOTE - maybe having System Preferences open had nothing to do with it ... it might have been me trying different keyboard combinations until one took ... I noticed that the keyboard shortcut won't record if OmniFocus doesn't like the combination you want ... so maybe it all comes down to the combination you are trying to put in ... the one that worked for me is Command Shift , (cmd-shift-comma).[/QUOTE]


(cmd-shift-comma) finally worked. thanks! I wish the system would just say Nope! can't use that one! instead of not knowing WHY it's not working.
 
Quote:
Originally Posted by pavementlook View Post
(cmd-shift-comma) finally worked. thanks! I wish the system would just say Nope! can't use that one! instead of not knowing WHY it's not working.
How about it says: "Nope! can't use that one because application <XYZ> is using it for Edit->Scramble Data Beyond Hope of Repair"? Wouldn't that be nice? An app that shows which key combinations are unassigned with a given set of modifiers would probably get some use, too...
 
Quote:
Originally Posted by Littleanty View Post
I had the same issue with assigning the clipping shortcut. Unchecking "Omnifocus: send to inbox" in System Preferences -> Keyboard -> Services and then trying again in the OmniFocus clipping preferences worked fine for me. Thanks qtus!
Having just needed to help someone new to OmniFocus with this exact problem, it looks like the solution is actually a bit simpler. Once you're at the Prefs > Keyboard > Keyboard Shortcuts > Services and see the Omnifocus: Send to Inbox option with no shortcut, you can just double click into that line and assign the shortcut there. No unchecking, rechecking, quitting OF, etc needed.

I double checked that this worked by immediately going back to OF on his computer, and the shortcut then appeared in the Clippings pane of the OF window as well, and a quick test showed it to be functioning properly.

May I suggest that this question and the solution be cleaned up a bit and added as a sticky to this forum? Looks like the issue comes up on a regular basis (I had to deal with it on my laptop a few months ago, and now again with my friend who I turned onto OF), but it wasn't that easy to dig through the threads to find the applicable solution...

Now, if only OF could get smart enough to actually *do* the tasks I have entered in there so I could go do more fun things than work... :-)
 
I know this is an old thread, so hopefully my answer is not redundant. Today I was unable to assign a shortcut key to the clipping service in the OF preferences. Like an earlier poster, I would set the shortcut but the shortcut was not displayed in the OF preferences and it wouldn’t work when tried to use the shortcut in other applications.

The solution I found is this:

1. Open OS X system preferences
2. Click on “Keyboard"
3. Click on "Keyboard Shortcuts"
4. In the left pane, click on “Services"
5. In the right pane, scroll down until you see "OmniFocus: Sent to Inbox"
6. Uncheck the box to the left of "OmniFocus: Send to Inbox"
7. Close OS X system preferences
8. Open OmniFocus preferences and set the clipping shortcut

I used the shortcut suggested in this thread: shift-command-period. Once I followed these steps, the shortcut was displayed in the OF preferences as one would expect.

Close and reopen any application from which you want to clip. For example, close safari or firefox or textedit and then reopen that application. The closing and reopening is necessary for the application to recognize the new universal clip-to-OF shortcut.

Hope this helps!
 
itmiller,

Thank you! I too had this problem and found the best way to fix it was to go directly to keyboard shortcuts. Didn't have to go back to OF again though.

Working now :-)
 
I really hope Omni improves this whole mess in future releases - coming from Things, which offers the exact same functionality however without the problems (assigning a combo just works and even all the apps, which are "incompatible" with OF, work like a charm), I'm a bit disappointed ...
 
I am a new enthusiastic user of OF but the assignment of the shortcut is a mess (I support Dirian_grey on that). It takes me 1 hour to found the solution... Finally, I assign the key directly by OSX system preference. Otherwise, OF is great!
 
itmiller,

It worked for me too. I do not know what you did but it saved me a lot of time. Next beer is on me.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
assign resource shortcut? clayc OmniPlan General 0 2012-04-03 06:24 PM
Cannot assign shortcut to clipping services after upgrading to Snow Leopard tosz OmniFocus 1 for Mac 9 2011-04-05 06:43 AM
Can't Assign Keyboard Shortcut mtennes OmniFocus 1 for Mac 1 2008-06-19 08:56 PM
How to assign a shortcut to an Apple Script? Tinchohs OmniFocus Extras 2 2007-12-16 07:18 PM
Re-assign a keyboard shortcut? Tinchohs OmniFocus 1 for Mac 2 2007-12-12 03:10 PM


All times are GMT -8. The time now is 01:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.