The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
AppleScript loses layout after save? Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
I'm trying to create a chart using AppleScript, letting OmniGraffle do the layout, my script looks like this:

tell application "OmniGraffle 5"
make new document with properties {template:"Blank"}
tell canvas of front window
set Node0 to make new shape at end of graphics with properties {text:{alignment:left, text:"blah"}, origin:{100.0, 20.0}, autosizing:full}
set Node1 to make new shape at end of graphics with properties {text:{alignment:left, text:"narg"}, origin:{100.0, 20.0}, autosizing:full}
connect Node0 to Node1
layout
end tell
save document 1 in "/tmp/output.graffle"
end tell


When I run this script, I see my nodes appearing all in one place, then I see the nodes getting nicely laid out as the automatic layout occurs, and then the file gets saved. However, when I close & reopen the file, the layout is gone - all the nodes are on top of each other as if the layout never happened.

What am I doing wrong?

Thanks,
Chris
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes



All times are GMT -8. The time now is 11:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.