The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
google search defect Thread Tools Search this Thread Display Modes
Hello: today, OW seems to be having difficulty on this PPC OS 10.5.8 mac, with the google main search page. The search field "disappears" to the upper left side of the window, and to the right of the "image" of some animate-able sport. I cannot see anything typed into the field, it is totally scrunched. This is unique to OW, the same field moves to upper left in Safari and Camino, but the field still shows what you type. I did check prefs and I do not see what to fix, if anything.
Read more "Your relationship to search engines" here
Thanks.

Last edited by sromni; 2012-12-08 at 06:48 PM..
 
Unable to reproduce on 10.4.11/PPC using OmniWeb/5.11.1/GM-v622.18 Revision: 159621 . Have you got OmniWeb's ad blocking configured and this is accidentally blocking some content required for correct layout?
 
Thank you for reply.
-before original post, I did check and after your reply, I rechecked. Disabling adblock changed nothing, the problem remains. I restarted OW (5.11.2) each time. Further, I booted into another partition, same OS 10.5.8 version, OW 5.11.1. Problem w/OW remains. It does not occur, again, in Safari which also uses webkit, I believe. The field moves, but you can see everything you type, in Safari.
 
This is also happening for me (OmniWeb v5.11.1 on OS X 10.8). I think the problem may be to do with Google's browser sniffing code, since setting the user agent string to OmniWeb 5.1 or Safari 4.3 seems to fix the problem.
 
Thanks, jonwhite. Went to "site prefs" in OW menu & changed as per your note. Good enough!
 
Jon's suggestion for browser spoofing restores a visible Google search box on the home page and results, but it turns off Instant Search, which I've grown to like.

A little more experimenting reveals that Safari 5.0.5 fails just like OmniWeb. So this appears to be an incompatibility with the version of WebKit in OmniWeb 5.11.2 and Safari 5.0.5 on 10.6.8.

Software Update on my 10.6.8 Mac says Safari 5.0.5 is the lastest release. But Googling about this problem revealed there's a Safari 5.1.7 release for 10.6.8. Safari 5.1.7 on 10.6.8 and Safari 6.0 on 10.7.4 work fine.

Let's all tell Google we'd like them to fix their search box for Safari 5.0.5 and OmniWeb 5.11.2: Google Feedback

Here's what I just submitted:

Quote:
Several days ago the search box disappeared on the Google Search home page and results page when using Safari 5.0.5 and OmniWeb 5.11.2 on Mac OS X 10.6.8.

The search box can be restored in OmniWeb using browser spoofing (as Safari 4.0 or OmniWeb 5.1), but Google Instant Search is disabled.

Please fix the Google Search box for the version of WebKit in Safari 5.0.5 and OmniWeb 5.11.2.
-- Ward
 
Sorry to hear of even more probs. Safari 5.0.6 works fine on ppc 10.5.8 (incl. instant search). Both safari & OW have "lucky" working in address field as always, which was the escape until the "change spoof" suggestion was posted.
-I have little hope Google will respond positively by doing anything, given their past behavior. I hope I'm wrong.
 
Sorry about this guys - the problem does appear to be with Instant Search, which you can disable in your google account preferences.

http://www.google.com/preferences?hl=en

I don't know why Google would have changed the browser requirements for Instant, since it has been working in OmniWeb for quite a while, but hopefully this will go away the next time we update WebKit in OmniWeb.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Google Search Sometimes Does Not Change Snow-Okami OmniWeb Bug Reports 0 2011-06-15 01:04 PM
fix for new Google image search superhancpetram OmniWeb General 5 2010-12-04 08:10 AM
Search in Google. globetrotterdk OmniWeb General 7 2008-11-02 06:00 AM
Google search emidwood OmniWeb General 3 2007-10-16 06:17 AM
Jagged edges around Google search box? Saad OmniWeb Bug Reports 4 2006-06-04 10:38 PM


All times are GMT -8. The time now is 05:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.