The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Mailaction.applescript missing ? Thread Tools Search this Thread Display Modes
Maybe I have this whole thing wrong, but it seems to me that the mail rule would send actions from mail to omnifocus. But for me nothing happens. I have configured the mail rule in omnifocus. When I check the mail rule in mail it seems that the mail rule should trigger a script located in /Applications/OmniFocus.app/Contents/Resources/MailAction.applescript

The problem is that I don't have any script in this location. I can't find mailaction using spotlight. Tried to delete all omnifocus files and reinstall with no success.

Any suggestions on what I'm doing wrong or what should be done to solve my problem would be greatly appreciated !

PowerBook, G4 1,33 GHz, 768 MB SDRAM
OS 10.5.1
Omnifocus 94800
 
Hi Joe,

What I did the first time I tried it was:

In OF's mail prefs:

Checked 'Add Mail Rule'
Clicked 'a Subject starting with' and set the string to contain 'OF:' (no quotes)
Checked 'Archive handled Messages
Select '@ACTION ITEMS' (on my Mac anyway) as the folder

I then went into Mail and sent myself an email with a subject of:

OF: Test, testing, 123

and clicked Send.

Moments later I looked in OF and there was my email in the Inbox and it was also in my '@ACTION ITEMS' folder in Mail.

Since you mentioned it I looked for and found (in the location you mentioned, MailAction.applescript). I'm sure I could email it to you if it would help :)

iMac Core Duo
OS X 10.5.1
OF 94800
 
Tried, and failed....

Seems the reason is the missing script. Would be delighted if it could be mailed to me

joachim.during@gmail.com

Thanx !
 
Quote:
Originally Posted by Joe Düring View Post
When I check the mail rule in mail it seems that the mail rule should trigger a script located in /Applications/OmniFocus.app/Contents/Resources/MailAction.applescript

The problem is that I don't have any script in this location. I can't find mailaction using spotlight.
The location that you specify is inside the OmniFocus application package. If you open the package and don't find the script, then you have a defective installation of OmniFocus and you should reinstall it.
 
Quote:
Originally Posted by brianogilvie View Post
The location that you specify is inside the OmniFocus application package. If you open the package and don't find the script, then you have a defective installation of OmniFocus and you should reinstall it.
Problem is I allready reinstalled the program package(after deleting all related files). Problem still persists, no script to be found(there is no omnifocus folder in my program folder, only the application). Could this be due to the fact that I partitioned my harddrive so application and homefolder are on different drives?
 
FWIW, I have the same problem. Just the app in the Applications folder.

Now granted, I just switched from PC to Mac so I might've installed it incorrectly.
 
Quote:
Originally Posted by Joe Düring View Post
Problem still persists, no script to be found(there is no omnifocus folder in my program folder, only the application).
The application is the folder. Applications in Mac OS X are "packages" of related files. If you select OmniFocus.app in the Finder and choose "Open Package" from the contextual menu (control-click or, with a two-button mouse, right-click on the application), you will see the contents.
 
Quote:
Originally Posted by brianogilvie View Post
The application is the folder. Applications in Mac OS X are "packages" of related files. If you select OmniFocus.app in the Finder and choose "Open Package" from the contextual menu (control-click or, with a two-button mouse, right-click on the application), you will see the contents.
Great, found the script as stated above. Thanks ! Still can't make it transfer my mails to the inbox. Tried to copy the script to another location and run the script with a mail selected, thereby bypassing the mail rule. Still no luck. Any suggestions ??
 
This is an old post, but it's July 2008 and I'm having the same problem - it looks like it's all set up right, the Mail Rule reads as it seems it should, but nothing processes into Omni Focus

Any ideas?
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
OF Applescript bug: querying for dates with missing values RobTrew OmniFocus Extras 2 2010-07-09 03:26 PM
Missing something, not OF, not OO.... ?? jpathomas OmniFocus 1 for Mac 9 2008-06-26 08:12 AM
MailAction.applescript doesn't create anything in OF Dalmet OmniFocus 1 for Mac 8 2007-11-18 10:19 AM
Missing Contexts macrael OmniFocus 1 for Mac 3 2007-10-21 07:09 PM


All times are GMT -8. The time now is 12:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.