The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Synch Time on Iphone is totally unacceptable Thread Tools Search this Thread Display Modes
Sorry, the slow performance is a bug. I haven't been able to reproduce this yet myself (my syncs are all still quite fast), but Brian did on Friday. Unfortunately, we didn't have time to get a full development environment set up with his phone before I had to leave on Friday, so I wasn't able to determine what was going wrongójust that something was.

I've been trying to reproduce the problem on my phone all day today, with no luck yet. As soon as Brian and I are back in the office tomorrow morning, I'm planning to finish getting the development environment set up for his phone so I can investigate further.
 
P.S. — Sorry I didn't chime in earlier, I haven't been scanning the forums for the last several days because I've been busy trying to track down this and other issues (mostly analyzing crash reports).
 
Thank you for the update Ken.

This isn't a problem I've been having, but knowing where things are at is always helpful when I am the one who's got the issue at hand going on.

Thanks,

Michael
 
Quote:
Originally Posted by mhammitt View Post
Same problem here: endless sync times. Checked OmniFocus.ofocus file on iDisk, cleaned out a ton of files, leaving those from this afternoon. Now I'm getting a "Unable to synchronize database with server" message, followed by "Unable to read document" and "No root transactions found in https://idisk.me.com/[username]/Documents/OmniFocus.ofocus/".

Can I just start from scratch, without losing my database?
O.K. I simply trashed the whole OmniFocus.ofocus package from the iDisk, did a new OF sync, and we're back in business. Didn't lose anything, at least, and no more syncing problems.
 
Quote:
Originally Posted by santra View Post
I guess if you make the mistake of ending task on the app while it's syncing, that completely corrupts the entire database, yes?, and you have to reload it from scratch, which I guess can take crazy long times.
I have not encountered this myself... I have done nothing in OF while syncing on iPhone, so my sync issues don't stem from this. Just an FYI.

Thanks for looking into it Ken! I'm going on a trip sans OF Mac, and have been worried that I'd end up losing any changes I make on OF iPhone while away. I'm sure it'll be all happy once I get back!
 
So what is happening when the double arrows on the phone are turning and what happens when it says Updating With Synced Data. In the first is it just locating the data on mobile me or is it locating and downloading? Is the second the result of the phone having downloaded the Database into a buffer and then writing it to the active Database?
 
I think OF for Mac is absolutely fantastic but the sync times for iPhone render it unusable as an app. Certainly not enough to be a "trusted system". Like a lot of OF users, we've been waiting for it but it makes web-based systems like toodledo or Remember the Milk real possibilities now.

I don't know enough about WebDAV to compare it against other options but I can't help but feel that it isn't going to work for anyone who uses the desktop version extensively. It is so great at clipping and "pulling data in" to be a comprehensive application that it runs counter to what the iphone and AT&T network can handle.

At this point, I'm really frustrated with the iPhone app.
 
I went to my webdav folder and renamed the OmniFocus.ofocus bundle to OmniFocus-backup.ofocus, and then synced OF on my mac. When that was done, I went to my iphone and synced from there, choosing the "From Server" option when prompted.

After that, the second syncs on both my mac and iphone took longer than they should, but did finish (mac took about 30 sec, iphone took about a minute or two). Since the 2nd syncs, the time they take to sync is less than 5 seconds for small amounts of change, on both devices. (This is with a db of 167 KB vs the old 831 KB version).

Whatever's going on, it has something to do with the syncing process, since that seems to be leaving the remote (iDisk/webdav) copy fragmented or something. Maybe the desktop app should be changed to occasionally do a complete re-upload.
 
We've tracked down the slow sync problem, and fixed it for the upcoming 1.0.3 release.

For the curious, the problem is triggered by a large number of transaction files: OmniFocus was trying to traverse the antecedent transactions for each transaction to figure out which transactions it needed to download from the server, and ended up in a Towers of Hanoi-like algorithm where every additional transaction made the process take nearly twice as long because we would revisit all the previous work yet again when looking at the new transaction.

The solution in 1.0.3 is to fix the algorithm to only look at each transaction once (which is how we meant for it to work in the first place), but a workaround you can apply now is to reduce the number of transactions by making sure each sync client connects on a regular basis (which lets OmniFocus clean up old transactions that it was only preserving in order to let out-of-date clients catch up). I guess that's why I hadn't seen this myself, yet; all my clients were connecting on a regular basis.
 
[While I wrote this, Ken posted the above post]

I have the same problems. Loading and syncing takes several minutes.

I had a look at my Mac's .ofocus file and noticed that it was about 3mb.
Some people at the forums thought this was really large so I ran the "CoalesceDatabase.scpt" script file supplied by Omni in one of those threads. It took the db size down to 1.2mb. No speed change in on the iPhone though.
Following this thread I checked the size and nr of files inside the .ofocus file on MobileMe and it was 1.7mb and contained 499 files while my iMac had 39 files. Something weird is definately going on with the nr of files here.

Ok so now I try the remove MM .ofocus file and resync with a fresh one from the iMac. There is still a lot more than 39 files in the online version compared to the stationary version. After several failed attemps and finder crashes (OSX does not like me to do file chores on my iDisk through finder, I had to use MM webclient at one point to delete the .ofocus file. Cloud version is now 1.1mb. Syncing is pretty much just as slow on iPhone.

Inside my iMac's .ofocus package there is one big file of 1mb. the rest of the 38 files are tiny. Whats that?

Even if I change nothing and resync on the iPhone it takes the same amount of time to sync. Is the sync not differentiental?

Last edited by colicoid; 2008-08-05 at 01:32 AM..
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bonjour sync totally broken on my Mac under 10.6.1 kidtreo Bonjour sync 15 2009-10-15 04:58 PM
How to use MobileMe to Synch the iPhone without Desktop OmniFocus SohoNYC OmniFocus for iPhone 3 2008-07-24 11:01 AM
iPhone synch - other apps do it wirelessly kimsenn@earthlink.net OmniFocus Syncing 1 2008-07-11 04:58 PM
Totally Unified Br Dan OmniWeb Feature Requests 10 2008-02-27 04:46 AM
Due dates totally off in view bar! hexatron OmniFocus 1 for Mac 2 2007-11-29 03:34 PM


All times are GMT -8. The time now is 01:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.