The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Other WebDAV
FAQ Members List Calendar Search Today's Posts Mark Forums Read

WebDAV sync problems Thread Tools Search this Thread Display Modes
I have two possibilities for WebDAV syncing, but neither is working.

The first is through I added an OmniFocus folder to my account, but when I tried to sync, OF throws up an error message that says

Unable to read document.
No root transactions found in

and doesn't sync. Any idea why this is happening?

My second possibility is through an account at This attempt fails at an even earlier stage with the message

untrusted server certificate

I understand this message, but every other application asks me if I want to trust the server anyway. OF doesn't.

I have to say this is pretty annoying. The application description at the App Store says "Synchronize OmniFocus with your Mac using the OS X version available separately from" I took this to mean that I could sync through iTunes. I had read about MobileMe and WebDAV syncing, but I didn't think they were required.

I bought OF for the Mac recently in anticipation of OF for the iPhone. If I can't get them to sync, they're useless to me. And I don't want to get MobileMe just to sync OF.

What do you suggest?
I forgot to mention that I'm using sneakypeek v77.4.0.102663.
I'm using the same sneakypeek version of OmniFocus, and am getting the same "untrusted server certificate" message. There seems to be no way to bypass this as you can in other applications.

Any suggestions are appreciated.
Are you guys able to sync via http instead of https?
I should have mentioned this in my initial post. Doing http instead of https yields this error consistently:

"lost network connection"
OK, I got OF on the Mac to sync to the WebDAV host with the untrusted certificate. I did a "Connect to Server" from the Finder, and when the notice came up asking if I wanted to trust that server, I clicked on the little "Always trust" checkbox. I then had to type in my Administrator password. Now OF on the Mac syncs via WebDAV. I should have thought of this earlier.

Unfortunately, my iPhone doesn't trust the server and is now putting up its own "untrusted server certificate" message. Any ideas on how to get it to always trust a particular certificate?
I haven't tried this out, but there's a tiny chance that doing an iTunes sync will sync the certificate trust over from your keychain?
Connecting to the WebDAV host via Finder works fine for me as well although even once I'm logged in (via Finder), attempting to sync in OF is still unsuccessful.

I'm using OSX 10.4.11, but I'm not sure if that makes a difference.

I put the iPhone in the cradle and resynced it through iTunes before trying to sync OF. The certificate trust didn't transfer.

I also just tried connecting to the WebDAV URL via Safari on the iPhone. It told me the certificate was untrusted and asked if I wanted to go there anyway. I said yes and got a directory listing of the WebDAV folder. Unfortunately, I saw no way to make the trust permanent, and OFiPhone still doesn't trust the certificate.

There are, I think, a lot of WebDAV servers out there whose certificates aren't signed by Thawte (or whoever else is considered authoritative). Omni needs to let us get at those servers.

Last edited by Mark Lawrence; 2008-07-10 at 01:22 PM..
OK, taking up troyb's suggestion, I changed my OFMac preference to a non-secure WebDAV using http:// instead of https://. The sync from OFMac *appeared* to work, and OFiPhone got further along in the sync than did before. There was no more "untrusted certificate" message when the sync started on the phone, and OFiPhone asked me for my username and password on the server.

Now there's a new error message:

Cannot copy.
Unable to get list of source files from file://localhost/var/mobile/Applications/blahblah/Documents/OmniFocus.ofocus/".

where the blahblah is substituting for a long alphanumeric string.

Looking at the WebDAV server, I see that the sync from OFMac has created a folder called "OmniFocus.ofocus-copy-in-progress-blahblah" which has nothing in it. This is apparently the same problem matt_c has been having (mentioned in another thread today).

In summary, using http instead of https gets around the certificate signing problem, but syncing still doesn't work. Apparently, OFMac is *not* sending the data to the WebDAV server.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
OmniFocus sync Using webDAV timtom OmniFocus Extras 5 2011-09-05 01:38 AM
Webdav sync of MBP seems very slow defilmj Other WebDAV 2 2008-11-19 11:08 AM
Problems with sync WebDAV (Bluehost) benwhite Other WebDAV 5 2008-09-28 07:47 AM
Subversion for WebDAV Sync? fudster Other WebDAV 5 2008-08-02 11:18 AM
Syncing problems with WebDav matt_c Other WebDAV 5 2008-07-10 05:35 PM

All times are GMT -8. The time now is 10:04 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.