The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Redirect after loading page Thread Tools Search this Thread Display Modes

I've had this problem on a few pages in the past, but could normally get away with just hitting the "Stop" button quickly enough. It might be time to report a bug though.

When I try to load this URL:

The page loads, but then I get redirected to:

Here are some possibly relevant lines from my Error Log:
2009-03-12 11:26:17 Error loading < ormat=160x600_as&output=html&correlator=1236817577 766&dblk=1& m%2F&color_bg=C3D9FF&color_text=0A1696&color_link= 0876DE&color_url=999999&color_border=C3D9FF&ad_typ e=text_image&frm=0&ga_vid=1540713516.1236817578&ga _sid=1236817578&ga_hid=851045524&flash=10.0.12&u_h =800&u_w=1280&u_ah=723&u_aw=1280&u_cd=24&u_tz=660& u_his=1&u_java=true&u_nplug=11&u_nmime=195&dtd=60& w=160&h=600&xpc=Iqdy0BkWYZ&p=http%3A//>: Operation could not be completed. (NSURLErrorDomain error -999.)

I'm not sure if this is an Omniweb bug necessarily - it could be easily be a problem with the sites's javascript or something. The fact is though, that the problem only shows up in Omniweb, so I thought it was worth reporting.

This behaviour occurs in the latest nightly I've got (5.9.2 v622.7.0.109981), but also occured in older version too.

Thanks for any help.
I think this bug is caused by the Google 'FriendConnect' JavaScript file. I found that adding '' (without the quotes) to the ad blocking settings prevented the problem and allowed the page to load normally.

However, it doesn't seem to be a problem any more in the latest 5.9.2 sneaky peek, using the Safari 4.0 WebKit version, so perhaps that has fixed it?

Hmm this still seems to be happening to me with v622.7.0.110050.

But other people can't replicate it? Weird.
I've fixed this by adding the below regex to my adblock list:

I guess I can't connect with my friends anymore haha but I'll survive.
I can confirm that the Oceanswim blogspot page still works for me (i.e. doesn't do the redirection) without needing any ad-blocking settings to fix it in both 110031 and the latest 110241. Maybe Google fixed their JavaScript? Either that, or I would think that the newer WebKit has avoided the problem.

If it's still not working for you with the same builds, then there's definitely something strange going on...

...but at least with OmniWeb's ad-blocking feature we always have a fairly painless workaround.
Thanks for the info David. It still seems to redirect for me. Damned if I know why.

I'm just using adblock now and that fixes it fine, so if nobody can replicate this, let's just say this is my bug rather than omniweb's maybe. Feel free to close thread.
I had exactly the same problem with two other blogspot links that jump immediately to that blog's version of the same page, though it happens by opening the second page in a new tab.
Since it doesn't happen with Safari or Firefox, it seems the problem is with blogspot, not OmniWeb. By disabling JavaScript on that page only I was able to stop the process
and have had no more problems.

Last edited by jwthomas; 2009-03-18 at 08:37 PM..
I'm having this problem as well. Will block Friend Connect as a stopgap measure; hopefully Omni will fix this soon.

Steps to reproduce:
1) Go to a website with Google Friend Connect enabled, like this one
2) Wait until OmniWeb redirects
The issue also affects ShareThis-enabled pages. For a temporary fix, block:


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Redirect omnifocus:// URL to OF1 jason.verly OmniFocus 2 for Mac (Private Test) 1 2013-05-07 04:33 PM doesn't redirect properly jdevalk OmniWeb Bug Reports 3 2006-07-27 01:03 AM
SP16: Focus not on page after loading zottel OmniWeb Bug Reports 1 2006-06-22 02:55 PM
Searcht started from the toolbar's search field: page loading hangs teorema67 OmniWeb Bug Reports 0 2006-05-07 01:56 AM
Error loading Boot Camp Beta Thank You page j.a.duke OmniWeb Bug Reports 0 2006-04-05 06:50 AM

All times are GMT -8. The time now is 05:10 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.