The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Clippings causing Services menu to hang Thread Tools Search this Thread Display Modes
Hi,

I'm having two issues with the Clippings:

1 ) Coming from Things, I'm trying to set the shortcut key to Shift-Opt-Space. Anytime I try and set that, it looks like the 'Reset' button gets clicked and the shortcut gets removed. I've tried and set it in the System Preferences pane manually, which leads me to....

2 ) Anytime I try and change the clippings shortcut, either in OF or in System Preferences, the Services menu hangs and just says "Building....". Rebooting or logging out does nothing to fix it. I have to use Cocktail to rebuild the launch services database to fix it. This is repeatable.

I've scoured the boards and haven't found anything for #2. I found a thread for #1, but that recommended manually changing the shortcut in System Prefs, which causes #2.

Any help you can give would be great.

- Griffin
 
Having the same problem.

If I try to assign a shortcut to clippings it will hang the services menu. Need to type this in terminal to get it to work again:

/System/Library/CoreServices/pbs

But when I open OF and try to assign a shortcut again it will hang again...
 
Jens, sorry for the trouble this is causing! What happens if you try the following steps when OmniFocus isn't running?

Launch System Preferences.
Open the "Keyboard Shortcuts" pane.
Switch to the "Keyboard Shortcuts" tab.
Select the "Services" tab in the list on the left.

What we're doing here is trying to differentiate between "OmniFocus is doing something that causes a hang" and "the system hangs; OmniFocus is then stuck waiting to get info back from the system".

If System Prefs hangs while OmniFocus isn't running, this may be something that a Genius Bar appointment would help resolve. If System Prefs works fine on its own but OmniFocus is still having trouble, email our support ninjas and we can try to figure out what's going on here. Sorry again for the trouble!
 
If I set the shortcut from the system preferences everything works fine...
 
Hmmm... if you email the support ninjas, we can figure out exactly what's going on in OmniFocus' preferences. Sorry for the trouble!
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio Recording Causing Crash fullcity OmniOutliner 3 for Mac 2 2012-10-01 03:15 PM
menu corruption using OO add to clippings kastorff OmniOutliner 3 for Mac 1 2008-04-24 07:43 AM
Downloads causing dock freeze in Leopard Bill Glude OmniWeb Bug Reports 0 2007-11-07 03:52 PM
OmniFocus Services Menu item greyed out fdlockhart OmniFocus 1 for Mac 6 2007-10-13 09:31 AM


All times are GMT -8. The time now is 10:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.