The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Changes not syncing correctly between computers Thread Tools Search this Thread Display Modes
Ok, this is just the start of this thread... I can't seem to figure out a pattern here.

I am syncing 3 clients. 2 computers and 1 iPhone. 1 computer is the one I work on the majority of the time. The second is a laptop that I take with me when I leave home sometimes.

I am syncing via webDAV (bingodisk).

My syncing up until today had been working GREAT.

So, the majority of my OmniFocus work is on Computer 1. All changes between that computer and my iPhone are working just fine.

However, when I sync the laptop (Computer 2), things go all wrong. For some reason, many of the changes that I made on Computer 1 don't seem to sync to Computer 2. These changes include:
  • Changed due dates not changing on Computer 2
  • Completed repeating projects not showing up as completed on Computer 2 (the repeat is made, but the original doesn't show as completed)
  • Completed actions within a completed project not showing up as completed on Computer 2
  • Reviewed projects not showing up as reviewed on Computer 2

There may also be other data that is not syncing across, but I haven't been able to isolate other patterns yet.

Some data syncs across from Computer 1 to Computer 2, like inbox items.

So, Omni ninjas... any ideas about what is going on here? Until I can solve this problem, computer to computer syncing is completely untrustable (and we know how important that is in GTD!).
 
After some testing, it seems like many of the problems revolve around repeated actions and/or repeated projects.

The only exception I see to that general observation is that my reviews aren't getting synced either.
 
I have a similar problem also with recurring actions.
I also end-up with duplications once in a while. I used the send feedback command to report the issue,
 
Repeating Actions especially seem to cause a lot of problems when syncing between machines. Forget syncing them to the iPhone at this point (IMHO) - any time I check one off on the iPhone it respawns three times!

I will send feedback to the right place too, but you are not alone...

This is synced to MobileMe, not webdav, BTW...

Last edited by wolfneuralnet; 2008-07-28 at 06:57 PM..
 
Ok, now my iPhone syncing is starting to exhibit these problems as well. I have a repeating project that has quite a few actions in it. The project repeats weekly. This morning, I completed a good number of the actions and checked them off in OF on the mac. I then manually synced the mac version and quit OmniFocus. Then when I opened OF iPhone and manually synced, those actions show up as uncompleted on the iPhone.

Of course, then when I opened OF on the mac and it synced with webDAV, those actions were then marked as uncompleted on the mac as well.

This behavior didn't appear until today. Does it have anything to do with the fact that I upgraded to 1.0.2 on the iPhone? If so, how can I downgrade to 1.0.1?

OMNI - PLEASE TELL ME THAT YOU GUYS HAVE FIGURED THIS OUT. Is a fix on the way? Do you have ANY idea what is going on?

At the very least, might I suggest you give us an interface where we can choose which data to use as the master? What I mean is, if there are two "states" for a given action, the software (both on the iPhone and on the mac) should give us the choice of which version of the action to keep. ACTION BY ACTION. I synced with a Palm device for years and this was DEFAULT BEHAVIOR.

I will chime in with everyone else who has stated that until this problem goes away, I'll have to view OmniFocus as unreliable - and that is simply unacceptable.
 
Yes, we've figured out the major cause of this. Yes, we're working on a fix. No, downgrading to 1.0.1 will not help.
 
Lizard - thanks for your reply. I really appreciate how the Omni developers have been so active here keeping us up to date on these kinds of bug fixes, etc.

It gives me peace of mind to know that you have figured out what the cause is. I look forward to the implementation of the fix!
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Syncing between iphone and two computers (variation) videotom OmniFocus Syncing 8 2009-02-05 07:48 PM
OmniFocus on Multiple Computers [USB, iDisk, .Mac, Syncing] Michal Young OmniFocus 1 for Mac 109 2008-07-08 12:06 PM
syncing between two computers SpiralOcean OmniFocus 1 for Mac 4 2007-11-19 02:26 PM
Syncing Between Different Computers johnmarkschofield OmniFocus 1 for Mac 10 2007-10-15 07:09 AM


All times are GMT -8. The time now is 01:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.