The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

iPhone/iTouch OF crashes at "loading" Thread Tools Search this Thread Display Modes
Anyone have a way around this? When I invoke OF on my iPod Touch, the "meter" appears and "loading" is displayed. Then the program exits and I'm back to the iPod's home screen. It seems as though the data file is corrupt and that chokes OF, but I'm only guessing. Since I can't get past the loading screen of OF, I can't get to preferences, etc.

Any ideas? Thanks. (BTW I do use the desktop version of OF and I sync using I tried deleting the OF backup on but that hasn't helped.)
Is there a way of resetting OF/iPod or deleting and reinstalling it? iTunes provides little maintenance capabilities.
Have you tried shutting the iPod off completely? That worked on my iPhone.
If that doesn't work, does the iPod have a reset facility? OK - I looked at the Apple support page and it does - try holding the Sleep/Wake button (at the top) and the Home button at the same time until the Apple logo appears
Yes, I did a complete shutdown, that didn't help. I'm now doing a restore of the entire system. This will take time, considering the number of songs that are syncing. I'll report back when I know what the outcome is.
No need to restore the whole iPhone.

You need to delete and re-install OmniFocus from the iPhone, which will wipe the data out of OF on the iPhone.

Make sure you have OF synched to iTunes before you do it... if you bought in iTunes it's easy, if you didn't then you need to right click the iPhone and select "transfer applications".

1) A complete shutdown did not fix the problem.
2) A full restore of the iPod did not fix the problem.
3) Deleting OF on iPod and then reinstalling via iTunes worked. I was able to do the initial sync with OF desktop/iDisk using the "get settings from Mac".

Thanks CatOne for your suggestion.
Originally Posted by pvonk View Post
When I invoke OF on my iPod Touch, the "meter" appears and "loading" is displayed. Then the program exits and I'm back to the iPod's home screen. It seems as though the data file is corrupt and that chokes OF, but I'm only guessing.
I had a similar experience when I first setup OmniFocus on my iPhone. Through a systematic (and tedious) process of elimination, I determined that the problem record in my OmniFocus database contained a graphic I had pasted in directly from OmniGraffle months ago. After removing that record, everything has worked beautifully.

Unfortunately, I haven't had time to try to reproduce the problem and haven't even reported it to the ninjas yet. I guess I should hurry up and do that.

Anyway, maybe this will give you a lead. Also, to delete OmniFocus and all its data on your iPhone, just tap and hold your finger on the app icon on the home screen. When the icons start to wiggle, tap the little "X" that appears on the OmniFocus icon. You can then reinstall the app by simply syncing with iTunes again.

Just to be safe, I turned off my OmniFocus syncing from my Mac before replacing OmniFocus on my iPhone. I don't know if it really mattered, but I'd much rather be safe than sorry.


UPDATE - Oops, just saw that you already resolved the issue. I really should reload my browser window before posting. :)

Last edited by Toadling; 2008-07-21 at 11:53 AM..

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
iTouch 2G OmniFocus sync with desktop (v1.7.5) stalls on "Preparing to synchronize" mattp52 OmniFocus for iPhone 4 2010-04-29 07:59 AM
How does OF for iPhone handle "Someday/Maybes" and "On Hold"? JRArseneau OmniFocus for iPhone 12 2008-08-04 05:56 PM
stop loading resources in "network activity" andreas_g OmniWeb Feature Requests 0 2007-04-11 09:05 AM
"Loading..." in blank tabs neilio OmniWeb Bug Reports 1 2006-05-04 11:29 PM
"Loading" title in tab drawer mileswu OmniWeb Bug Reports 1 2006-04-28 01:27 PM

All times are GMT -8. The time now is 06:44 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.