The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Automatic update not working Thread Tools Search this Thread Display Modes
Since OF switched to using tbz2 my automatic updates do not work. The file is getting downloaded with an extension of .tbz2.txt and I have to rename it to remove the txt part of the extension. After I do that I can install the update manually.
 
Patricia - I jut updated the server so this does not happen.
 
Quote:
Originally Posted by Mindflayer View Post
Patricia - I jut updated the server so this does not happen.
Something's up, as the last several days of downloads are downing as .tbz2.bz2 , and OF gives errors when trying to open the file.
 
I just tried this and I'm not having any weird file naming issues. If this problem persists, please let us know whatever you can about your configuration (particularly if you are using any sort of proxy server, download accelerator plugin or whatnot). If any one else is hitting this, please let us know too!
__________________
CTO, The Omni Group
 
I have reported this via email previously (twice, in fact, in build 94313 (either bug #228382 (in the subject) or #205101 (in the body), and again for 94382 (#229109)). Here's the message that was generated automatically:

Code:
Error: Unable to open package.
Reason: (null)

Details:

{
    NSLocalizedDescription = "Unable to open package.";
    NSLocalizedRecoveryOptions = ("Report Error via Email", Cancel);
    NSLocalizedRecoverySuggestion = "Unknown package type.";
    NSRecoveryAttempter = <OFMultipleOptionErrorRecovery: 0x160a9400>;
    "com.omnigroup.framework.OmniFoundation.ErrorDomain.FileLineAndNumber" = "/Volumes/Disk/Users/Shared/omnibuild/ReleaseProduct/Source/OmniGroup/Frameworks/OmniSoftwareUpdate/OSUInstaller.m:71";
}
I can't think of anything on my system which would lead to this, as nothing's changed on my system or network in the last couple of months, and it happens regardless of where I download from (at work, at home, at a friend's, etc.)

Console generates a message "2007-11-19 21:42:08.317 OmniFocus[2505] Ignoring unknown track 'sneakypeak'" when I click "Check for Updates now" in Preferences, every time.

The file is written out as "OmniFocus-r94800-Alpha.tbz2.bz2" immediately (i.e. it's not being changed by something else).

I'm on 10.4.10
 
The error message in this case is just due to the mangling of the file name; so the real error has happened prior to this.

The message about the unknown track is due to a long-past error in packaging our OmniFocus release; it should be benign, but you can avoid it with the following in Terminal:

defaults remove com.omnigroup.OmniFocus OSUVisibleTracks

As to why the file name might get mangled; my only guess is that somehow Apple's downloader is deciding to rename the file. This could happen if the web server tells it to use a different file name than the original path used in the URL. If you are hitting our extremesims mirror, this shouldn't happen, but if you are getting a copy passed through a proxy server or some other mirror, then a server misconfiguration could cause this.

Beyond that, there might be come client side configuration that would cause this, but I'm unaware of what it might be, other than the options I suggested.

Has anyone else hit this problem and arrived at a solution? This is the first I've heard of it, but maybe someone else has...?
__________________
CTO, The Omni Group
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Spell checking: Automatic by language not working anymore ozean OmniOutliner 3 for Mac 3 2012-03-20 02:57 AM
Lost badge counts after iOS 5 update [A: caused by update; re-enable in Settings.app] Warwick24 OmniFocus for iPhone 4 2011-12-22 01:53 PM
Automatic Layout with Automatic Re-alignment michael.prescott OmniGraffle General 0 2010-03-10 06:27 AM
Sneaky Peek update not working sperkinz OmniFocus 1 for Mac 7 2008-07-31 08:18 AM
New update function not working with non-admin account John Stalberg OmniWeb Bug Reports 1 2007-09-05 10:02 AM


All times are GMT -8. The time now is 01:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.