The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniOutliner > OmniOutliner 4 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Latest upgrade crashes every time Thread Tools Search this Thread Display Modes
I just had an automatic upgrade (4.0 test v162 r196336) and it crashes repeatedly on opening.

I get an OmniGroupCrashCatcher message that reads: NSInternalInconsistencyException: Unable to swap task exception ports (os/kern) invalid argument (code 4,mask=0x0000107e)

This happens every time I try to open an 003 file. If I merely click on the OO4 icon on my dock, it opens OO4 just fine. But if I then try to open an existing file, it crashes. Every time.

Which means I cannot work on any of my outlines. How do I restore the previous version? Clearly, this latest upgrade is flawed.
 
This same message has been returned to me:

Quote:
Unable to swap task exception ports: (os/kern) invalid argument (code 4, mask=0x0000107e)
except I got when trying to upgrade from r196372 to r196376. I rolled back to 372, but got the same message when I clicked on "Reopen windows." When I started it again I skipped that step and was presented with a blank file. I then tried to open a recent file and the message above returned.

I wonder, though, if it's actually the The Omni Group Crash Catcher that's throwing up the message. When I try to quit or force quit that I get the same message, even when .oo4 is not running.
 
I've gone back to using OO 3 - everything opens fine it.
 
Sorry about that. This is caused by hyperlinks in the document. The last good build should be http://omnistaging.omnigroup.com/omn...96268-Test.dmg

You can always return to the omnistaging page to download a past build when major regressions are introduced. We're working on memory management issues right now that has been causing this instability.
 
Thanks Derek. And yes, the earlier build works fine now.

How will we know when this issue is resolved and it's safe to switch to the latest upgrade?
 
Ideally it would be noted in the release notes but not everything makes it in there. Mostly just trial and error, this crash is high priority though so it shouldn't be long. I'm trying to keep an eye on the builds and pulling bad ones, but any builds later in the evening likely won't be checked till the morning.
 
This crash has been fixed in r196516.
 
Yes it has. Thanks!
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes



All times are GMT -8. The time now is 05:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.