The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

"Unable to execute SQL" means... what? Thread Tools Search this Thread Display Modes
I keep getting an error box that says "Unable to execute SQL" when I am just moving stuff around. I click OK and things continue to work fine. This is the first time I;ve seen the message in the week I've had OmniFocus, but it does it non-stop now.

What did I do or not do for this to be happening? I'm sure it is a simple thing but for the life of me I cannot figure it out and don't see it in the FAQs. (Of course, it is probably obvious... but not to me!)


It sounds like something is corrupt in your database. I strongly suggest that you connect the support ninjas at (or just choose Help → Send Feedback).

Sorry for the trouble! This could be a cache issue let's try the following:

- Open a Finder window, and navigate to Library/Caches

- Move the folder com.omnigroup.OmniFocus to the Trash

- Relaunch OmniFocus

Does that help? If not, or if you have any other questions, as Curt said, contact our Support Ninjas by email and we'll troubleshoot from there.

Last edited by Brian; 2009-08-19 at 01:35 PM.. Reason: add missing word.
@hollywood I don't know if it worked for "newfie", but it worked for me perfectly. So, thanks a lot for your hint!
removing the omnigroup folder from user/library/caches just did the trick for me as well. Issue popped up after an upgrade to Snow Leopard.
Hollywood, thanks. This worked for me as well. The problem occurred after I ran the app CleanMyMac. Maybe something got messed up when it cleaned the caches and libraries.
I have the same problem, and it occurs after every time I run CleanMyMac -- any clues has to how to stop CleanMyMac interfering?

Originally Posted by jeremyk View Post
I have the same problem, and it occurs after every time I run CleanMyMac -- any clues has to how to stop CleanMyMac interfering?

Tell it to not clean caches.

Or, quit _all_ applications before running it, and reboot IMMEDIATELY after cleaning caches. It's a REALLY bad idea to clobber caches underneath an app while it's running.

Frankly, the best thing is to just not use "clean my mac" more than once a year or so. It's not necessary.
I had the same problem and I fixed by running "rebuild database" under the Omnifocus "file" menu
I had the same problem. My Library/Caches folder didn't have the folder mentioned above and I couldn't quit, but I found the rebuild database solution recommended by jimmygster worked for me. HOWEVER! I lost all the changes I'd made since the problems started happening (luckily only earlier today) so if you do this, make a copy of everything you've added recently or try doing a backup.

The problem started happening after I used MacKeeper's cleaning utility (while Omnifocus was running) so I guess that explains it.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to FIND text in columns that have the type property set to "pop-up list" qomni OmniOutliner 3 for Mac 20 2013-12-04 04:18 PM
NOT APPLICABLE TO OMNIFOCUS 2: What to do about "Unable to open zip archive" error? timomni OmniFocus 1 for Mac 14 2013-10-02 05:51 AM
"Unable to Execute SQL" after 10.7/Lion update. [A: Rebooting Mac resolves.] khcole OmniFocus 1 for Mac 7 2011-07-21 07:43 PM
"unable to execute sql" every time I click into OF - any ideas? Tetsugaku OmniFocus 1 for Mac 1 2011-05-12 11:15 AM
"Unable to push calendars" error on iCal sync tomm iCal Sync 2 2007-09-01 07:42 AM

All times are GMT -8. The time now is 05:01 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.