The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

OmniGraffle hangs on startup Thread Tools Search this Thread Display Modes

I'm not sure what's going on with my install of OmniGraffle. It hung today for reasons unknown so I force quit to try and restart it. Unfortunately, I just get the spinning beach ball of death; the application fails to start.

In my console I see the following message:
29/01/09 9:22:38 PM OmniGraffle[452] This version of OmniGraffle has a newer Spotlight importer (1.4.2) than previously run ((null)). Requesting a re-index of files handled by our importer.

I left it alone ~10mins hoping it would "reindex" but it never seems to finish. I've also tried the following:
- Using AppZapper to uninstall OmniGraffle and reinstall it. The same problem persists.
- Starting OSX as another user (I thought maybe some data it stores in my user directory is corrupt).

What can I do?

I'm running OmniGraffle Standard 5.1.1 on a vanilla OSX 10.5.5.
I'd start off trying a fresh set of preferences -- you can manually set aside or delete your OmniGraffle preferences (located at ~/Library/Preferences/com.omnigroup.OmniGraffle.plist where ~ is your Home Folder) and see if that makes any difference.

Hope that helps,
"Vroom! Vroom!!"
Hi Joel,

Thank you for your suggestion. It works!
Well, the problem has reappeared. Deleting the preferences doesn't seem to make a difference anymore. I've even tried installing the trial version of OmniGraffle Pro but it does the same thing.

Every now and then the application will work when I start it (but rarely). When I close it and re-open it later, it hangs again.

It's really frustrating; I'm trying to get some work done and I can't!

Is there anything I can do to diagnose this better? Does OmniGraffle have a verbose mode for instance? The only thing I get in the Console is what I posted initially.
I'm sorry for the trouble that this is causing! You'll want to contact the support ninjas - they'll ask you to run a "Sample" report, which will tell us what code OmniGraffle is busy running while it's being unresponsive.

The output of a sample report isn't very forum-friendly, though.
Thanks Brian. I've fired off a message to the omnigraffle support email.

About this report thing: can I run it myself without any special software? Is it just extra parameters I need to pass to the binary in order to invoke it?
Open Activity Monitor in your /Applications/Utilities folder and under one of the menus is Sample... (not on my Mac at the moment so can't say which). Select the OmniGraffle process in the main window then select Sample... from the menu.
Just wondering if this is being addressed in the next release.
I spoke with Paul via email who I think lodged this as [OG #406192].

It's quite an annoying bug that only appears when I'm disconnected from the work VPN (and seems to be related to not finding my printers). Anyway, it seems OG looks for my missing printers (and thus stalls) quite alot, even when creating a new document (so not just on startup).

I'm hoping there is a fix coming soon.
I had the same bug. OmniGraffle worked fine at work, but persistently hung when I opened it at home. When I VPN'ed into work, it worked fine. Perhaps it was hanging because it couldn't find the work printers?
It seems that this bug has reappeared in the latest versions of OmniGraffle (5.1.1-5.2.1b2). Is there any solution to this problem?

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
OmniOutliner hangs with 100% CPU Petter OmniOutliner 3 for Mac 2 2011-09-22 10:38 AM
Omniweb hangs under OSX 10.7.1 Lion borrel OmniWeb Bug Reports 0 2011-08-19 06:10 AM
delays and hangs with browser duderonomy OmniWeb General 11 2009-06-13 03:12 AM
gmail gets screwy and hangs pergesu OmniWeb Bug Reports 2 2008-05-06 01:56 PM
this url hangs OW 5.5.1b1 Gregory OmniWeb Bug Reports 1 2006-11-02 11:11 AM

All times are GMT -8. The time now is 01:47 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.