The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
"Open Linked Mail Message" not working Thread Tools Search this Thread Display Modes
I downloaded the new build of OF and now whenever I click on the "Open Linked Mail Message" (with the relevant OF action selected) I get this error message (and am unable to open the intended email message):

AppleScript reported the following error:
OmniFocus got an error: Can't make «class OTva» of tree 30 of tree 5 of content of document window id 412 of document id "eXSANI_7mpt" into type reference.

HELP! I have hundreds of linked messages so this is a huge problem. :(

Thanks in advance,
Jennifer
 
Quote:
Originally Posted by jenniferp View Post
I downloaded the new build of OF and now whenever I click on the "Open Linked Mail Message" (with the relevant OF action selected) I get this error message (and am unable to open the intended email message):

AppleScript reported the following error:
OmniFocus got an error: Can't make «class OTva» of tree 30 of tree 5 of content of document window id 412 of document id "eXSANI_7mpt" into type reference.

HELP! I have hundreds of linked messages so this is a huge problem. :(
Jennifer,

You need to download the new version of my Mail scripts. Omni changed the AppleScript dictionary in a recent build, necessitating minor changes to several of my scripts.

Also, in the new Mail scripts, the link-back script is named "Open Linked Item". This also works with links created using my Send URL to OmniFocus script for Safari, or with any OF item that has a URL as the first line of its note field.
__________________
Cheers,

Curt
 
I downloaded the scripts and installed them, but I'm not clear on the last graph of your message.

I looked in the Customize Toolbar section of OF - do I need to install
a) 'Update Mail Link to New Format' and
b) 'Open Linked Mail Message'

Then use a, then b on a linked action?

If so, it doesn't seem to open the relevant email message.

Jennifer
 
Great. Now nothing at all works. Just a ton of error messages.
 
Quote:
Originally Posted by jenniferp View Post
Great. Now nothing at all works. Just a ton of error messages.
I'm glad you appreciate my volunteer efforts.

Perhaps I'll just pull down the scripts so no one else is harmed so grievously.

I've just posted a new version of the scripts, 0.7.2, that I hope fixes all the bugs introduced by OmniGroup's backward incompatible changes.
__________________
Cheers,

Curt
 
Dear Curt -

I thanked you for all your help several times in private email and I'll thank you again here on the Forum. (Thank you!)

It turns out that the problem was two scripts which weren't in the scripts download link posted above, so I'm grateful for you - as I'm sure others would be - sending along the proper ones.

No need to take out your frustrations on me.
 
I'm sorry about that Jennifer. I only recalled one thank you, after my post here. Looking back through our conversation, you were more gracious than that. I was incredibly pressed for time and was getting a "You broke things and lost all my data" vibe. Your initial messages were very gracious, so I'm sorry that I was rude, both publicly and privately. I hope you will accept my apology.

I need to stress to everyone, however, that my scripts are provided as-is. If I had been on vacation or incapacitated when Omni changed the scripting interface, then my scripts would just stop working. If individuals have critical data behind my scripts, then they are risking that data. I think it extremely unlikely that OmniFocus development will stop. It is substantially more likely that I won't be able to update my scripts at a particular point in time.

The only scripts of mine that used a proprietary format were my Mail scripts pre-version 0.5. The current version of my mail scripts stores Mail links as MailTag URLs. So if people are up-to-date with script version, the only risk is that people will need to find new ways to manage their systems. No data should be lost if I'm hit by a bus and then Omni changes something in their code.

I'm also very pleased to see that Mail integration is still on Omni's roadmap for version 1. My Mail scripts are really just "duct tape and baling wire" until the features are baked in.
__________________
Cheers,

Curt

Last edited by curt.clifton; 2007-09-12 at 12:29 PM.. Reason: Fixed gramatical error
 
Apology accepted, Curt. :) No worries.

Thanks again for all of your efforts. They are definitely appreciated.

Jennifer
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
"bad URL" message on exports (other than text) Mawbry OmniOutliner for iPad 2 2011-08-05 05:26 PM
stop annoying "has not been synchronized" message jackdempsey OmniFocus Syncing 2 2010-08-26 11:23 AM
Mail's "Show in Mailbox" can't find a filed message Ward OmniFocus 1 for Mac 4 2009-05-26 10:56 AM
SOLVED: Sync always triggers "no longer compatible" message IntlOrange OmniFocus Syncing 6 2008-07-23 10:39 AM
"Message (1) processing took 22 ms" hijacking my status bar pergesu OmniWeb General 1 2008-06-30 09:06 AM


All times are GMT -8. The time now is 04:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.